Xauth


#1

Hello,

I have an ios xauth APP that worked flawlessly with the API 1. Now I only get http 404 or 410 error when trying to obtain the auth tokens. I can’t find a hint what do I have to change…is it just the API URL? Or is xauth no longer supported? Any help is very much appreciated !


#2

xAuth is still supported for apps that have access to it, though if you’re on iOS you really owe it to yourself and our users to use the more user-informative web-based OAuth flow instead.

If you’re seeing HTTP 404 or HTTP 410 codes, it’s likely not an issue with using xAuth itself but instead what you do after obtaining a token – any API calls you make to api.twitter.com/1/* need to move to API v1.1 equivalents. Review the docs on this site to understand further.


#3

Thx you for the hints! Yes you are right, I get the token and even the home time line works now. But I still can’t update statuses. The URL seems correct https://api.twitter.com/1.1/statuses/update.json, now I get 401 errors. Do you have any more tips?


#4

What have you tried so far in debugging? POSTs are handled a little differently in OAuth, but the main trick is making sure you encode the status parameter correctly the first time.


#5

I think I found the problem: in the end I had 401 errors that seem to come from incomplete url encoding of the status update. Strangely enough since I leave out brackets in status update like “(” and “)” it works…