xAuth problem: consumer key and secret don't work


#1

I have a problem: every time I try to authorize my application I get an 401 error. I’ve tried different solutions, then I tried to replace my consumer key and secret with someone’s else and surprisingly the app works. How can I solve this problem?
Here is my OAuth details:
Access level Read and write
About the application permission model
Consumer key xxxxxxxxxxxxxxxxx
Consumer secret xxxxxxxxxxxxxxxxxxxxxxxxx
Request token URL https://api.twitter.com/oauth/request_token
Authorize URL https://api.twitter.com/oauth/authorize
Access token URL https://api.twitter.com/oauth/access_token
Callback URL http://smarturl.it/notizie
Sign in with Twitter Yes


#2

Are there details included with the 401 error? Does the key you’re using have permission to use xAuth?


#3

No, there are no details. What do you mean with permission to use xAuth? Do I need a permission?


#4

Yes – xAuth requires explicit permission from Twitter to be able to use. Permission is only granted to applications that have no other means to secure web-based authorization (such as environments where a web browser is completely unavailable). Most modern applications and operating systems provide some means to perform web-based authorization, so it is seldom awarded in the present day.