Wrong Rate-limiting in v 1.0 OAuth authenticated calls


#1

I’m getting the 150 calls per hour limit even though I’m going through OAuth in v1.
The OAuth part works fine as it was tested with v1.1.

X-RateLimit-Reset: 1357519379
X-RateLimit-Remaining: 148
X-RateLimit-Limit: 150
X-Access-Level: read
X-RateLimit-Class: api

Does the 350 OAuth limit still exist for v1.0 of the API or it has been lowered ?

Thx


#2

This is weird. It happens in /1/users/lookup.json but it doesn’t happen in /1/statuses/user_timeline.json which shows the correct ratelimit:

X-Access-Level: read
X-RateLimit-Limit: 350
X-RateLimit-Remaining: 349
X-RateLimit-Reset: 1357520446
X-RateLimit-Class: api_identified

Any ideas?

Thx


#3

The v1 limits are still the same as they’ve always been.

Do you use any parameters in your usage of users/lookup that might have characters in them you’re not encoding correctly? (Such as commas ?) Since users/lookup in v1 allows unauthenticated access, if you get your OAuth wrong we’ll often defer to an unauthenticated context.


#4

Seems I’m not the only one noticing this issue lately: https://dev.twitter.com/discussions/13097
The same OAuth params and requests work fine on v 1.1 so there is definitely something wrong with that particular method: users/lookup.json
I’ve also tried OAuth tool for users/lookup.json with my application which generates the cURL commandline and has the same issue. This last method can’t be wrong, there’s something definitely going from Twitter REST api side.


#5

I’m getting the 150 calls per hour limit with OAuth in v1,too !!!

Rate limit API (https://api.twitter.com/1/account/rate_limit_status.json) shows that “remaining_hits” always stay in 150 when I’m going through OAuth in v1.

But it looks normal when I use Rate limit API without OAuth.

I can not understand what happened…


#6

Can you check if happens only on users/lookup.json and not on statuses/user_timeline.json ?

Thx


#7

Not every issue that looks similar on the service has relations to each other. Some of our API methods in API v1 are stricter than other methods with OAuth and HTTP. API v1.1 as a whole is much stricter about both OAuth and HTTP than API v1. Very subtle errors or inconsistencies in HTTP libraries and OAuth libraries can cause issues.

Can you detail your request to users/lookup that is failing? The exact URL you’re executing. The exact parameters you’re sending and whether they’re in the query string or in the POST body. The HTTP method you’re using. Your signature base string. The HTTP headers you are sending. All of these are participants in what can go wrong in HTTP and OAuth.


#8

I’m using OAuth tool to sustain my issue claim and I get the exact same results. Can you please test users/lookup for v1 on your account ?
https://dev.twitter.com/docs/api/1/get/users/lookup
I’m using the OAuth tool from the right which generates a correct cURL command line.

Thx,
Daniel


#9

Any news on this issue ?