WP to twitter not working OAuth error


#1

I’ve ran WP to twitter without problem until last week. Nothing had changed, no site or app updates, I just received an OAuth error telling me credentials weren’t correct or that the OAuth key & secret were invalid/wrong.

I’m not a coder, just a mediocre blogger so I have no idea what to do to fix it. I tried getting a new key but it still didnt work. I tried deleting and setting up a new connection but that didnt work. WP to Twitter support not responded and can’t find anything recent on this kind of problem that makes any sense to me.

Can anyone help me out without confusing me?
thanks in advance


#2

I should say I cut n paste the keys so they shouldnt be wrong


#3

Check that the time on your server is correct. It’s possible that the clock has gradually gotten out of sync with the Twitter servers.

Another possibility is that the key you used was revoked. Try regenerating your app keys and repasting them into the application.


#4

it shows me “401 Unauthorized: Authentication credentials were missing or incorrect.”

what do i do


#5

I’m getting this error message: Connected, but getting a notice that your Authentication credentials are missing or incorrect? Check whether your Access token has read and write permission. If not, you’ll need to create a new token.

I’ve copied and pasted the 4 codes, and the token is set for read/write. I even tried regenerating them. Still same problem.

The times on the two servers match.

I just set this up on another web site and it worked perfectly. Can’t figure out why this one won’t.


#6

Same as ScottLewisPhoto - mine isn’t working either and I’ve done all the same stuff. Guess I’ll try deactivating the plugin, removing it and reinstalling it…


#7

How do you fix the server clock?