Won't return all funding instruments


#1

https://dev.twitter.com/ads/reference/get/accounts/account_id/funding_instruments

This API call is suppose to return all funding instruments, however it only returns one. Also there is no field in the funding instrument that would indicate it as being the default. This is shown on Twitter’s Ads UI.

We also tried it on twurl, same result.

This is what we are using on twurl: twurl -H ads-api.twitter.com -X GET "/1/accounts/18ce53v046c/funding_instruments?with_deleted=true"


#2

Hi @tal_asad,

Do the other funding instruments that are not showing up happen to be IOs?
Carmen


#3

I am not sure what you mean by IOs, but they show up on the Twitter Ads API. They are regular credit cards.


#4

Hi @tal_asad,

I just took a look at that account, and it looks like it only has one funding source. Are you perhaps looking at the wrong account?
Carmen


#5

That account has 3 Credit Cards, I also have access to 2 other accounts. Another one has 2 and the API also returns just 1 for that one.

Have a look at this screenshot:


#6

We’ll take a deeper look and get back to you


#7

Hi @tal_asad,

So turns out this is the expected response - you should only see one credit card funding instrument in your account. The funding instruments are not the same as payment methods/funding source. There is one funding instrument that represents the credit cards in the account, so you would change the default via the funding sources settings page you navigated to above.

Let me know if this answers your questions!
Carmen