Widget shows Direct Messages, how do I stop this?


#1

I want to use the Widget to show Public tweets and not Direct Messages, is this possible, as its shows both?


#2

Twitter widgets don’t display direct messages – do you mean you don’t want it to show @mentions and @replies? Which widget are you using?


#3

Yes, sorry thats what I meant. I using the Profile widget.


#4

There’s currently no explicit option to configure the widget that way. If you’re experienced with Javascript, you may be able to add the “exclude_replies=true” parameter to the request for the “user timeline.”

There’s a part of the widgets.js file that looks something like:

if (this._isProfileWidget) {
this.url = this._base + ‘&callback=’ + this._cb +
’&include_rts=true’ +
’&count=’ + this.rpp + showSince() + ‘&clientsource=’ + this.source;
}

Which you could change to:

if (this._isProfileWidget) { this.url = this._base + '&callback=' + this._cb + '&exclude_replies=true&include_rts=true' + '&count=' + this.rpp + showSince() + '&clientsource=' + this.source; }

#5