Widget domain


#1

The twitter widget I was using for my site stopped working, and now I only see the “Tweets by …” placeholder text. I’ve looked this up here and the given solution is to whitelist my domain within the widget configurator. But when I go there, there is simply not any option to list domains. I’ve even looked up tutorials online which provide screenshots of this–which show an option which I don’t have. There should be a “domain” field under the “link color” field, but I only have the “save changes” button. What is the problem here? How do I whitelist my domain?


#2

There’s no need to whitelist domains anymore.
What is your site’s URL?


#3

OK, that’s good to know. My page is www.briandavis.name/twitter.html.


#4

Brian, I’m in the exact same situation.

Woke up this morning to find all my embedded Twitter widgets are broken and only showing the “Tweets by…” text.

I’ve been reading the same stuff about the domain whitelisting except as you said it doesn’t appear relevant anymore.

Visiting your site I see the same thing as I do on all of mine.

http://www.strideacademy.co.nz/

The heck is going on?


#5

This is the JS error I’m getting in the browser console:

Unable to load timeline. widgets.js:8

Would be great if we could get some help - this has been working fine for months.


#6

i think this is twitters problem, not yours. it also happens on the twitter api documentation page: https://dev.twitter.com/docs/embedded-timelines . hope it gets fixed soon.


#7

We are experiencing the same problem on our website www.mhs.mcdowell.k12.nc.us


#8

Seem to have the same problem with the widget on my business site as well

URL: http://theontimetechguy.com

Has been working fine ever since I had to create a widget with the ver. 1.0 API being shut down but the last couple of day I have noticed the widget disappearing. Thought it was because of an error I made while changing some javascript on my site so I recreated and re-uploaded the widget with no luck. I even tried pasting the widget code into a blank page and testing it on my personal web server and get the same result

URl: http://1013clan.no-ip.org


#9

same here. two websites with widgets. and surfed others… looks like all widget feeds are down right now.


#10

Same in Germany, too: http://www.aids-kampagne.de


#11

same here in Egypt :slight_smile: all widgets stopped , i think the server is down or something :frowning:


#12

even the widgets on the twitter api pages are down. seems to be a bigger issue…


#13

Widget (not loading) problem, seen in New Zealand (thought it was just my acct for a moment) too.


#14

Anyone tell me what data-dnt=“true” means?


#15

Answering my own question, via here…

https://dev.twitter.com/docs/embedded-tweets

Opt-out of tailoring Twitter

Twitter widgets on your site can help us tailor content and suggestions for Twitter users. If you want to opt-out of this feature, set the optional data-dnt parameter to be true. Learn more about tailoring Twitter.


#16

The widget work fine for me on your page.


#17

Seems to be working now.


#18

unable to create my widget


#19

I have the same problem. Sometimes the feed shows up and sometimes only the “Tweets by…” is shown.
In firebug’s net tab I can see a request to:
http://cdn.syndication.twimg.com/widgets/timelines/342974518698053632?domain=mySite.se&lang=sv&t=1532977&callback=twttr.tfw.callbacks.tl_342974518698053632_1&suppress_response_codes=true
If I open this link I can see the twttr.tfw.callbacks for my widget. (twttr.tfw.callbacks.tl_342974518698053632_1({“body”:"\u003Cdiv class=“root timeline ltr customisable-border”…")
But on those occations when the feed is not seen on my page, the link returns an empty page. If I however modify the url and add “www.” before de domain name ie “www.mySite.se”, the twttr.tfw.callbacks is return ok.

Is the http://cdn.syndication.twimg.com loadbalanced and half of the servers need the “www” on the domain to make it work or what??

Anyone has a clue?


#20