Why does this image render as a summary instead of a photo card?


#1

This tweet renders as a photo card correctly: https://twitter.com/dblocktest/status/246447500783923200
This one does not: https://twitter.com/dblocktest/status/246446354413518849 (renders as a summary with the correct thumbnail)

First image is art.sy/artwork/peter-alexander-6-slash-1-slash-12-blue-square
Second image is http://art.sy/artwork/peter-alexander-untitled

I read the docs twice and I can’t find a reason why this happens. Is it because the first image is Twitter blue? :slight_smile:

Thanks,
dB.


#2

Weird, looks like the second image may not have had the correct markup when it was crawled, and a summary card was cached instead. You can see a photo card if you Tweet http://art.sy/artwork/peter-alexander-untitled?q=1234 for example.


#3

Got it. How/when does the cache expire on Twitter-side for new tweets?

Found your https://twitter.com/fakekurrik/status/246665934306172928 tweet, which is now correct. I assume you cleared that on your side. Do let me know if there’s anything we should/can do here to avoid this in the future.

Btw, didn’t get an update on this thread either (no email or anything), had to remember to come back here to check on the status of things.

Many thanks.


#4

It should just expire with time. I believe the current threshold is about a week, although there are some factors which may change that.

This bites some sites when they initially implement cards and are changing their markup, but shouldn’t be much of an issue once you stabilize your tags.

For the email alerts, were you subscribed to this thread (see the button up in the top right).


#5

Ok, I wasn’t subscribed to this thread. You’d think it would auto-subscribe me when I start it :slight_smile:


#6

For expiration, it would be nice if there was a way to force expire an url or do a card without hitting the cache. I am sure there’re people adjusting tags in development being completely puzzled by this behavior.

Anyway, thanks for your support.


#7

The cache is now shorter, 24 hours.


#8

Thanks for the suggestion, it makes sense. We currently don’t have this option, but we are considering it.