Why am I getting 'Failed to find ProxyImageByMinDimensionsResponse for ...' error in the cards validator?


#1

We are getting this error for the url in the ‘twitter:image’ tag while trying to validate a url for the first time. After the first unsuccessful attempt the error is dissappears. We have tried both the original AWS S3 storage url and Cloudfront proxy url for the image, the result is the same. Here are the meta tags returned:

<meta property="og:url" content="https://www.pickr.us/#!/poll/69" />
        <meta property="fb:app_id" content="489917224417572" />
        <meta property="og:title" content="Hangi #superman daha yakisikli? @pickrMovie  " />
        <meta property="og:image" content="https://s3-eu-west-1.amazonaws.com/srdc.pickr/5/bf42e837-43f4-41ef-abc6-4816689fbacd" />
        <meta property="og:image:width" content="320" />
        <meta property="og:image:height" content="320" />
        <meta property="og:site_name" content="Pickr" />
        <meta property="og:description" content="" />
        <meta property="twitter:card" content="summary" />
        <meta property="twitter:site" content="@pickrus" />
        <meta property="twitter:domain" content="pickr.us" />
        <meta property="twitter:title" content="Pickr.us" />
        <meta property="twitter:description" content="Hangi #superman daha yakisikli? @pickrMovie  " />
        <meta property="twitter:image" content="https://s3-eu-west-1.amazonaws.com/srdc.pickr/5/bf42e837-43f4-41ef-abc6-4816689fbacd" />
        <meta property="twitter:image:width" content="320" />
        <meta property="twitter:image:height" content="320" />
        <meta property="twitter:app:name:iphone" content="Pickr.us" />
        <meta property="twitter:app:url:iphone" content="pickr.us://p/69" />
        <meta property="twitter:app:name:ipad" content="Pickr.us" />
        <meta property="twitter:app:url:ipad" content="pickr.us://p/69" />

#2

Me too, same error. Someone can help?


#3

Also getting this problem. Thought it might have been caused by the image URL not ending with the right file extension, but even with a ‘.jpg’ at the end, it doesn’t want to work.


#4

Same here… Any further information on this?


#5

We are getting the same error. Did you guys figure this out?


#6

I’m getting it too. I’m thinking that there is a bug. Has anyone reported it?


#7

We’re also having this issue. Any update?


#8

I got this working. My images were too small (they are 160x160 minimum). They prefer square images and I also added the extra height and width tags to make sure. This is the page that helped me: https://dev.twitter.com/docs/cards/types/product-card


#9

Could you provide the URL where these meta tags are used?

And if it helps others on this discussion, each card has its own minimum image requirements. For example,

  • Summary: 120x120
  • Summary with large image: 280x150
  • Product: 160x160

#10

Hi,
I’ve got the same problem. Twitter card validator says “Failed to find ProxyImageByMinDimensionsResponse for …” but I’ve checked all above answer without success.

This is my twitter card:

The image is 300 x 201, so it’s greater then minimum requirements. What’s wrong?


#11

@jbulava
We don’t find that image requirements. Sometimes fetching on validator fails just because of a time delay. It works smoothly :slight_smile:


#12

I too am having this issue. In fact, this was working perfectly yesterday, and today it is not. I have changed nothing in my metadata or my image hosting (s3) The code can be found at :

but copied below it is:

    <meta name="twitter:title" content="Zen of Technology" />
    <meta name="twitter:description" content="Tap the link to read a sample of this book." />
    <meta name="twitter:image" content="https://s3.amazonaws.com/aerbook/books/3955/assets/cover.jpg" />

The error I’m getting is:
Failed to find ProxyImageByMinDimensionsResponse for https://s3.amazonaws.com/aerbook/books/3955/assets/cover.jpg


#13

Same problem for me here, e.g. with http://apollogate.com.au with the following metadata

This was not previously a problem, but I notice that the documentation is now recommending twitter:image:src not twitter:image; is this enough to cause the problem?


#14

OK, a possible cause for me (and maybe others) is that our robots.txt at http://cdn3.rwaws.com/robots.txt is denying access to everything.

What is the user agent for the twitter card validator, so that I can get it whitelisted?


#15

Hi @elyobo

If you use twitter:image:src problem persists.

Paco


#16

Hello Nick,

I think the reason why your image is not appearing is because Twitterbot could not verify the access rights. Here is a solution for you.

  1. Use your S3 bucket as a subdomain to get control by reversing the URL:
    https://aerbook.s3.amazonaws.com/books/3955/assets/cover.jpg

  2. Provide a robots.txt file on this subdomain to make sure Twitterbot can access your images:
    https://aerbook.s3.amazonaws.com/robots.txt

    User-agent: Twitterbot
    Allow: *

Please keep us posted but I’m confident this will solve your issues.


#17

OK, we ended up having fixing two problems and now things are working for us.

  • The robots.txt was disallowing access, this has now been corrected for Twitterbot
  • The og:url metadata was incorrect, which was breaking links in Facebook; this has also been corrected and coincided with Twitter cards working correctly again, but I’m not sure whether twitter was paying attention to this or it was just a coincidence.

@pakusland, thanks, I figured it wasn’t necessary to change as others are using just twitter:image, but given that the docs are now indicating twitter:image:src should be used perhaps we should be updating? It’s a shame that the docs don’t mention the change and timelines if the old version is deprecated.


#18

is wrong, you got the tag name wrong it must be twitter:image:src. YOu missed the src part
corrected

and if oyur image is larger then 160x160 px it should work


#19

Thank you for your response. A prior posting requested I have a “Robots.txt” which I had. The code inside is:

User-agent: Twitterbot
Allow: *

User-agent: *
Disallow: /

I now have both a Robots.txt and robots.txt. Same code in both. The file has been updated, but the validator still failed. I believe it may be caching, so I will try it again in the future. The odd thing is, the Robots.txt file I added was about 4 weeks ago (maybe more) yet this issue only popped up 3 days ago.


#20

We hit the same problem. Our entire site is behind SSL and we were using standard secure S3 links for image assets. S3 seemed to be adding headers that maybe Twitterbot couldn’t figure out.

I’m not entirely sure which part of this process worked but here’s what we did and it fixed the issue:

  1. CNAME’d our S3 bucket so we now have http://cdn.mydomain.com/[imagepath] available

  2. Updated twitter card images to use this alternative path

  3. Added a robots.txt to the root of the S3 bucket allowing access to everything:
    User-agent: *
    Disallow:

  4. Enabled static website hosting in S3. This seems to make nice headers and let Twitterbot get proper access.

Voila! Cards working again. Now to change all those image source paths… :-S