Whitelisted Fabric and TwitterApp can't retrieve email

email

#1

Hi,

I have a Twitter app created through apps.twitter.com. This app is already whitelisted, it has both Fabric and email requesting permissions but I couldn’t find a way to include the keys from this app in my project (for iOS) which already had Fabric self generated keys.

My confusion is which keys should I include in my .plist as APIKey, Consumer key and Consumer secret. I am able to authenticate a user but will always get an empty value for the email with all the key combinations (from Twitter apps and Fabric) I’ve tried.

Thanks!!


#2

@amelinagzz

If your Twitter consumer key and secret that were generated via apps.twitter.com and have the permissions you need, you can replace the Twitter consumer key and secret generated via Fabric in your info.plist. If you want, you can also setup the override mentioned here.

-Mike


#3

I tried both options before my first post with no success :confused:
Here’s the dictionary setup in my .plist :

Fabric

  • API Key : API key self-generated by Fabric (which is not the same as the one at fabric.io, but I tried also with the one at fabric.io)
    Kits
    -KitInfo
    – consumerkey : key from apps.twitter
    – consumersecret : secret from apps.twitter
    -KitName : Twitter

Overriding with keys from apps.twitter before passing the shared instance to Fabric had no effect too.
I suspect I’m mixing the wrong keys.


#4

@amelinagzz

This is still happening even if use the existing apps.twitter.com keys? You can check those keys at that dashboard, but your Fabric API key here after selecting your organization and then clicking on API key underneath your organization’s name.


#5