Where do I request an access token?


#1

I’ve created an application, have my consumer key & secret, but can’t find anywhere my access key. I see no right-hand drop down menu to request one, trying in Safari and Firefox with all pop-up blockers and scripts off. This is needlessly complicated. Two hours just to set up OAuth is more than enuf.


#2

Agreed…what happened to request access token request option…trying to use wp-twitter for wordpress and I just need the access token and access token secret.


#3

The “my access token” feature will return to your application configuration pages within the next few days.

Until then, you’ll have to obtain the access token through the standard OAuth flow. There are a number of tools that can make obtaining this token easier for you, including Twurl http://github.com/marcel/twurl and the OAuth Dancer http://github.com/episod/oauth-dancer – if these seem too complex for your scenario, my best recommendation to you is to wait until we restore the my access token feature. More about the OAuth negotiation flow can be found at [node:115].


#4

Nice, I’ll look out for some more helpful details like when the “my access token” feature might actually return since it has been removed for some unknown reason. The workarounds are a little complicated for a simple blogger to install the wp-twitter plugin.


#5

Thanks for everyone’s patience while we put the finishing touches on this feature in the new dev.twitter.com.


#6

The “My Access Token” feature is back. As usual when it comes to Client Applications management, note that your changes may take a moment to reflect.


#7

Can I change the access level of my access token to “read and write”?


#8

Right now the best way to accomplish this would be to go to http://twitter.com/settings/applications and revoke access to your own application. Then come back to dev.twitter.com/apps and make sure your app settings are the way you’d like them to do be. Then create the access token again by invoking the feature. If you’re feeling cautious, there are some caching issues from time to time so you may want to add a little bit of time in between steps.


#9

Hi, excuse me, i’m having a really strange problem and i get no help.

I used oAuth in my app, and well, when I run my app in the iPhone simulator, it works good, I can authenticate and give access to the app and tweet messages. When I run the app in a real iPhone, I get the “this page is no longer valid, it seems someone else…” error.

I’m becoming crazy and i cant fix it. Dose anybody knows what is happening? I would really appreciate help.

THANKS IN ADVANCE!!!


#10

Well, I did that 23 hours ago. Until now the problem persists.
The access token of my account is still there, and the access level still is “Read Only”. Is there any other solution?
Should I delete the application and start all over again?


#11

Same issue here, sort of. Create application, go to “create access token” - there’s no option for read only/read & write, etc - theres just a button to create access token, when that’s clicked it creates an access token as “read only” which cannot be changed. The previous GUI was much simpler and straight forward, this new one seems like it’s got a ton of bugs.


#12

i got the same problem, revoked access to the app, and it still says its there and read only, really need this read-write… this new gui is not good!.


#13

Same problem here… Have you got a way around this?


#14

Also same problem here on a brand new accounts. I’m just trying to add my new blogposts automaticly via a script. Code is just fine since I can use the application with an other account.

I tried setting the permission to Read/Write but that didn’t work. After a while i found this tread: https://dev.twitter.com/discussions/387

@TheFrugalFlambe pointed out the following:
Had to create the access token AFTER setting the main account settings to read & write.

So here’s what i did:

Since I could found a way to “reset” or “renew” the access token I simply created a new application, then set the permissions to read/write. After that I created the access token.

Read/write access since then. Kinda strange that the “read/write” setting didn’t updated the permissions of the access token.

Anyway-> Fixed now!


#15

I found the only thing that works is remove the application all together


#16

Confirm!
First change the permission
Then generate the access token

Thanx man!


#17

We just fixed the “My Access Token” feature.

Note we also added a new option to ReCreate your Access Token. If you needed to update your token access level (i.e. just after changing your Application access level), you could directly use the “Recreate my access token” button, instead of revoking your existing token and create it again.


#18

Hi there,
Keeps telling me over and over again every time I try to get an Access Key: “Your OAuth access token has been successfully created.” BUT, there is nothing that shows up. I have successfully done it for 2 of my other websites. It’s frustrating already. Even tried to delete the application and start all over for that website. Said it was deleted it but it’s still there, in 2 different browsers. Not sure what to do at this point…Thank you.


#19

I reset my keys and then did a create access token and it worked. Now I see that my application twitter tools on wordpress doesn’t seem to register correctly still. Any ideas anyone? Looks like the twitter end is all correct although Twitter tools setup page mentions setting the application to browser which doesn’t appear in the settings at all on Twitter. Thanks


#20

Hi guys,

May be you have an idea on the following:

I created an application,
in the application page in “Details” tab I see “Your access token” section.
I click “create my access token”:
the page updates, I see the message that it’s created, but “Your access token” section does not display any details about the token (it still looks the same as it was before I clicked “create my access token” button).

Am I doing something wrong?
How can I get that token?

Thanks heaps in advance for ideas.
(I’m not very savvy with twitter tokens)

Cheers,
Natalie