When I Embed, Only a Link Appears


#1

I’m trying to embed a search feed into a website, but when I do, there’s only a link that directs my guests to another page. What am I doing wrong? Thanks for your help.


#2

Can you post the embed code you’re using?


#5

I tried to post it, but the code caused the system to “hide my message”


#6

The embed code should look something like this:

<a class="twitter-timeline" href="https://twitter.com/hashtag/corgis" data-widget-id="622188967140569088">#corgis Tweets</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>

Does your’s look like that?


#7

Mine doesn’t hashtag…it’s just a search term. Maybe I need to hashtag it.


#8

still not working…doesn’t that “href” always make it a link?


#9

Did you create a timeline widget or are you just putting a link to Twitter search in your page? If you haven’t created a timeline widget, you can go here to do so. After you create a widget, you’ll see the embed code you should use towards the bottom of the page.


#10

I’ve done this. When I paste that code into the html, all that appears is a link when I update and look at the page.


#11

A Twitter timeline embed consists of two pieces: a link and JavaScript which loads to enhance the link into a rendered timeline. If you are just seeing the link it’s very likely your CMS stripped the JavaScript.

View source of the page. Search for platform.twitter.com. Did you find anything? The script should appear near the link.

Also check to make sure you have not enabled an ad blocker which might block Twitter’s JavaScript. Disable during your testing just to be sure.


#12

Thanks, Niall. I’ll check on this. The JavaScript issue seems like it’s the one tripping me up. I’ll report back.


#13