Weird API Authentication Issues


#1

I realize this is probably a WHM/cPanel server or Wordpress config issue, but I’m hoping one of you has encountered this before and can at least point me in the right direction.

This was working under a different Twitter account in WP, but I suspect a WP update caused it to die since WP and several plugins were updated around the same time. I’ve tried 3 different auto tweet plugins (two with an oauth tester) and they all fail authentication.

I’ve tried reissuing all the API credentials as well as deleting and starting over on both the WP side and the API side as well as testing multiple plugins on a different blog of ours. I got one test account on Twitter to work, but I can’t duplicate it now on the live Twitter account and I can’t figure out what’s different. I tried switching it back to that, but I’m no longer sure which of the three plugins actually worked with that Twitter account now. (Yes I’m kicking myself for not documenting that at the time.) I just assumed I could replicate it under the live Twitter account at the time.

I read on another forum that server time could be off and I checked that local time was correct and I see UTC in the server logs for WP, which I know the Twitter API uses.

Is there a test I can run from the command line on the server, WHM, or cPanel to see if the server is the issue and then if it’s okay can I test under WP without using the plugins? I just need something to go on here and I’m happy to trace through logs, etc. if someone can tell me what to look for and where. There has to be a simple explanation and solution for this. Obviously I’m not the only one using WP to auto tweet with.

And the WP plugin developers aren’t going to be much help if I can’t even get it to authenticate now. I feel like a complete moron for not being able to debug this.

Thank you in advance for any thoughts or suggestions!!


#2

RESOLVED - I revoked and reissued the API setup from scratch again for about the 4th time. In addition it seemed to pick up a space before a couple of the keys when copying & pasting into the plugin in WP. Not sure if it was the space or reissuing it that resolved it, but hopefully this will help someone else.