Webhooks: Could not authenticate you error

oauth
auth
error-codes
webhooks

#1

I have been trying to register my webhook url for a while now and all to no avail. I’ve generated the required keys, properly set up my OAuth Authentication logic but it still doesn’t work. This is despite the fact that other endpoints work, I have posted tweets with the same set up, retrieved direct message and timeline but just this endpoint (https://api.twitter.com/1.1/account_activity/webhooks.json) never works.

I have used Postman, had to install Ruby and get Twurl and even used a Node script I found in one of the many threads I’ve searched while looking for an answer. They all returned;

{"errors":[{"code":32,"message":"Could not authenticate you."}]}

This is genuinely sad and disappointing and I would appreciate every help I can get.


#2

That sounds like an issue with the way you’re signing the request or building the OAuth headers.

Have you applied here? Has your app been granted access to the Account Activity API?

You’ve tried to do this using twurl? Can you share the command line you’re using?


#3

Thank you for your response Andy,

No, I haven’t applied. That is probably the problem as it’s the only thing I haven’t tried. The documentation didn’t really mention applying before one can use Webhooks.

I use the default Command Prompt on Windows and this was the command I entered;

twurl /1.1/account_activity/webhooks.json

I’ve applied now, please do you know how long verification would take?


#4

The team usually processes applications on a weekly basis so it may take a few days (and it will depend on your use case being approved) - unfortunately I’m unable to provide any further insight here.

See this statement on the first page of the documentation:

Access to the Account Activity API (beta) currently requires completion of an application and whitelisting from Twitter. Go here to complete an application for access. We are reviewing applications as soon as we can, but bear with us as we expect to have a lot of developers applying for access.


#5

Oh, wow. What a silly error on my part.
I sincerely apologize for wasting your time, I don’t know how I missed that.

Thank you very much for your help.
Regards.


#6

I’m having the same issue as the original author however I did apply using the new Account Activity API form (https://developer.twitter.com/en/apply). But I keep getting the message:

{
    "errors": [
        {
            "code": 32,
            "message": "Could not authenticate you."
        }
    ]
}

I’m making the API call to https://api.twitter.com/1.1/account_activity/webhooks.json and tried using twurl. I did the same scenario before with the old request access form and it did work before but it seems like something changed that broke the endpoint?


#7

I think you need https://api.twitter.com/1.1/account_activity/all/env-beta/webhooks.json during the beta, if you have been provisioned for the all activities endpoints.