Webhook subscribing, got High latency on CRC GET

webhooks

#1

Hello!
After than my app was whitelisted, still have problems with subscribeing to webhook.

Got his error:

{“errors”:[{“code”:214,“message”:“High latency on CRC GET request. Your webhook should respond in less than 1 second.”}]}

I tried to calculate the response time, and it was less than 0.5.
Server in Germany.

Or with Twitter i can use only servers from USA???

Why i have error about high latency?


#2

I start performance profiler and got this stat’s for webhook response:
User CPU time 0.089 msec
System CPU time 0.013 msec
Total CPU time 0.102 msec
Elapsed time 0.108 msec
Context switches 0 voluntary, 0 involuntary

it much lower than 1sec.


#3

@KyleW,
pls need ur help

this is reponse table:
http://ping-admin.ru/free_test/result/1519672345cmjvf8w8pop6n5x45c7v3.html


#5

hi, can you share your webhook callback URL, or if that is not possible, can you please let us know if it contains a non-standard port number or anything else that might be unuusual? Thank you.


#6

start url:
https://immp.rwp2.com/twitter/

callback url:
https://immp.rwp2.com/twitter/callback/

p.s. on callback url no this strict in 1sec.
callback url generate request to setup webhook.

excerpt from API:

The CRC request will occur

When a webhook URL is registered.
Daily (once per 24 hours) to validate your webhook URL.

Response requirements

Valid response_token and JSON format.
Latency less than 1 second.
200 HTTP response code.


#7

Is this issue solved? I am getting the same issue at the time of webhook creation. I am making post request from postman and crc get request is giving proper response but still getting the error:

{
“errors”: [
{
“code”: 214,
“message”: “High latency on CRC GET request. Your webhook should respond in less than 3 seconds.”
}
]
}

Please help with this.


#8

Where is your webhook application running? If you’re in a hosted service like Heroku free tier then the app may get put to sleep after a couple of hours, and the CRC endpoint may take longer to respond.


#9

Webhook application is running on glitch. For your reference this is my endpoint https://joyous-may.glitch.me Btw I am getting this issue while requesting the webhook url.


#10

Is that the URL where the CRC request is being posted in, or do you have another endpoint defined?


#11

Yeah that is the url where crc endpoint is defined. Look below for actual reference of both post and get requests.

  1. Post request url (https://api.twitter.com/1.1/account_activity/all/nikitest/webhooks.json?url=https%3A%2F%2Fjoyous-may.glitch.me%2Fwebhook%2Ftwitter) along with OAuth which I am doing from postman.
  2. This is my get request endpoint https://joyous-may.glitch.me/webhook/twitter

#12

I’ve just tried sending a GET request with a CRC to that endpoint, and it is hanging / timing out, so I think there’s something wrong in your app not responding successfully.


#13

When the request came to my app it took 2-3 ms. But not sure why there is no response received on your end.

Look the reponse from the get request:
Timestamp - 1528441205866
crc_token - YWFkMTljYTgtMTk4OS00ZmM5LWJlNzMtZGZkODNiZmVkZmJi
{ response_token: ‘sha256=UJyPXBs1HLFg3bPS1e5g60/V6bNQ3Kh7vVntuc0I1e4=’ }
Timestamp - 1528441205870


#14

Thanks got the issue solved.


#15