We have a custom URL shortener, but all URLs revert to t.co


I’ve built a URL shortener using YOURLS that is intended to brand our orchestra, complete with a bookmarklet for our patrons/audience/site visitors to use if they wish. While our custom URLs (symp.ws, for Winston-Salem Symphony) appear correctly in our feed when viewed on twitter.com/wssymphony, they appear to have reverted to t.co URLs when our feed is viewed on our website (wssymphony.org) and on various twitter client smartphone apps. I see others’ tweets including custom URLs with su.pr, goo.gl, bit.ly, etc. Did I miss a step? Is there a vetting process through which I need to apply our shortener?

Thanks for any help,


How are you retrieving and processing the feed you’re displaying on your website? Are you including [node:127] when you retrieve your timeline (setting the include_entities parameter to true)?

If you do so, you’ll notice an entities attribute in the status object, that contains parsed and structured data (url, media, hashtag…) extracted from each Tweet. The urls entity is the one you’ll be the most interested in. For example, with Tweet #93325601502543872:

“urls”: [
“expanded_url”: “http://symp.ws/n”,
“url”: “http://t.co/JRRz8YU”,
“indices”: [
“display_url”: “symp.ws/n

You can use display the expanded_url, but be sure to hyperlink it (href part) to the url.


Thank you for the reply, Arnaud. I’m using Aaron Campbell’s Twitter Widget Pro wordpress widget to display our tweets. I’m pouring over the plugin’s php files now to see if I can integrate your recommendation somehow. I’m a trombonist, not a developer (yet)!

Are you hinting at the fact that I could include our feed on our site with code only and without a widget (in case I can’t customize the widget php to include Tweet Entities)?


Hola que tal