WARN: No metatags found


#1

INFO: Page fetched successfully
WARN: No metatags found

https://www.leeagra.com/blog/arkansas-shipment/

I even copied a successful page from another website that worked and it doesn’t work from our server.


#2

Something weird is going on with your server config.

$ wget -U Twitterbot https://www.leeagra.com/blog/arkansas-shipment/
--2015-11-02 16:57:21--  https://www.leeagra.com/blog/arkansas-shipment/
Resolving www.leeagra.com... 64.50.176.57
Connecting to www.leeagra.com|64.50.176.57|:443... connected.
HTTP request sent, awaiting response... 403 Forbidden
2015-11-02 16:57:24 ERROR 403: Forbidden.

Using curl -A Twitterbot I also get a 403 forbidden, but a page is returned anyway.


#3

We have a strong firewall. What IPs should be whitelisted for Twitter?


#4

Our IPs and ASNUM details are on the Cards Troubleshooting page.


#5

Hi, I’m having a similar issue.

We are using a dot net web forms cms with c#. When I try to validate the following URL, the meta tags are not found (these are meta tags from another site which worked):

http://staging-web2.turn2us.org.uk/cardtest/test

I created a blank website with one web page, on the same server and the validation works:

http://cardtest.turn2us.org.uk/


#6

The problem seems to be with our certificate. The technicians are working it out. Thanks for all replies.


#7

Hold the phone. My technicians say the certificate is fine.

https://www.digicert.com/help/ says both leeagra.com and www.leeagra.com check out.

They say WGET is way old and not to be trusted.


#8

That’s fair, and I used curl first, which still returned 403 forbidden (along with content) - this could well be confusing the validator, or something else might be going on.

curl -A Twitterbot -t <url>


#9

Hi @andypiper, do you have any suggestions about how to check the following URL?

http://staging-web2.turn2us.org.uk/cardtest/test


#10

Your page loads in a browser and appears to have some Cards tags in it. However, trying to retrieve the page with a user-agent set to Twitterbot as above, results in an HTTP 403 Forbidden error. I suggest you fix your nginx configuration.


#11

SOLVED Thanks all for helping.
.htaccess:
SetEnvIfNoCase User-Agent “^Twitterbot” search_bot

Order Allow,Deny
Allow from all
Deny from env=search_bot


#12