WARN: No metatags found


#1

I have meta-tags on the web page. I have created a robots.txt file for Twitterbot. But nothing is displaying. Even in the preview below its pulling an image through but the card validator says no metatags.

Have done everything on this page: Not Whitelisted, unable to render, or no image: READ THIS FIRST

But I’m still not getting anything. Anybody have any suggestions?


#2

There’s no Content-Type header returned by your webserver, so the cards crawler doesn’t understand what kind of document it is looking at.


#3

Hi Andy,

Okay so would adding this to the <head> be enough for it to read it?

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />


#4

I think it’s the actual HTTP web server itself that is not setting the Content-Type header.


#5

I have a .htaccess file in the backend of the website that should be setting the content type:

<FilesMatch “^[^.]+$”>
  ForceType text/html
</FilesMatch>

Is that what you mean?


#6

I guess that might be it, but it doesn’t seem to be working. I see these headers when I curl the URL. I’d expect an explicit Content-Type to be returned.

< HTTP/1.1 200 OK
< Date: Mon, 30 Apr 2018 15:00:38 GMT
< Server: Apache
< Last-Modified: Mon, 30 Apr 2018 08:45:23 GMT
< ETag: "b1a1ade-3a73-56b0cdfe70151"
< Accept-Ranges: bytes
< Content-Length: 14963
< Vary: Accept-Encoding,User-Agent

#7

Hi Andy,

Ah, that sounds like a problem (not a twitter one). I know its not really your job given that it’s not a twitter issue but do you perhaps know how I might fix it? Or are you able to point me in the direction of a tutorial/walk-through that might be able to?


#9

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.