Validation Request Failed - "Reason: is not a valid screen name"


#1

Received email from you (Twitter support) saying the url for twitter cards did not vailidate
for my food blog site www.scrumptiousscran.com - and have gone through the
validation process again. Everything checks out and I press the request
validation button and complete the form. When i press “request approval” I
get the error message:

Something went wrong and your request to be added to the whitelist failed.
Please try again.

Reason: is not a valid screen name

The Screen Name is completed - I tried using both my own name - Chris Berry -
and the Twitter account name - Scrumptious Scran, but still no success.
The only thing I can think is that “Website Twitter Username” field on the
form is grayed out and won’t let me enter anything. This is despite the “twitter:creator” and “twitter:site” both being validated.

I have been waiting for approval for a Twitter card for several weeks now,
and have found the process to date so unhelpful I am about to give up on
both the cards and Twitter, as it is really putting my marketing of the
site at a disadvantage.

Hope you can reverse my disappointment in Twitter…

Chris Berry aka Scrumptious Scran


#2

I have exactly the same problem. It seems that the “Website Twitter Username” is either inappropriately disabled or erroneously not being autofilled.

Using Chrome Developer Tools, I was able to add a value=“username” attribute to that input (where username is my Twitter handle for my website). Then the form submitted OK!

This seems like a definite bug on Twitter’s end.


#3

Jeff - thank you so much! Did exactly the same in Chrome and was able to submit. I’d had a response from Twitter - finally - merely saying that they had been a bug and to try submitting again, but exactly the same issue, so effectively useless.

Thanks to your work around - which shouldn’t be necessary, so get it sorted Twitter! - my card is now approved.

Many thanks once again…


#4

Could you tell us how to fix it in details? How to use Chrome Developer Tools?


#5

Thanks for the feedback. We just pushed out a fix to the error that was preventing the input URL field from working. Please re-submit via the Validator Tool, and let us know if you have any additional issues.


#6

I still have that error.


#7

I seem to be having it as well


#8

Can you provide an example URL for us to test?