Using Twitter signature generator curl gets 401 error


#1

I started getting 401 errors. I can duplicate the problem here…

https://dev.twitter.com/oauth/tools/signature-generator/1812246

Using the signature generator, I generate the request then use the curl command line, curl returns with the 401 response.

This is the endpoint that is returning the errors…

https://api.twitter.com/oauth/request_token

To duplicate the problem this is what I am doing…

  1. Go to…
    https: // apps.twitter.com/app/1812246/permissions
  2. Click “Test OAuth”
  3. Change the Request URI to…
    https: // api.twitter.com/oauth/request_token
  4. Click “Get OAuth Signature”
  5. Copy the curl command
  6. Paste the CURL command into the console

I have tried the curl command from Linux, 3 different Amazon EC2 Libux instances, I have also tried it from my OS X Workstation.

I added spaces to some of the referenced URL’s twitter didn’t like any more than 2 URL’s

Is there a way to notify someone from twitter that the signature generated from their signature generator isn’t autheticating when using the curl command they suggest.

I have been successful at making requests to the twitter API in the past but they have just recently started failing. Is there a better place to post my question/request for help?

This topic has been added to the OAuth list it is also found on the API list but I am not sure to which it applies.


#2

I am still not able to use /oauth/request_token

I can however reach other endpoints on the API. This problem just strated in October right around the time of the sslv3 issue.

For example I have no trouble reaching…

https://api.twitter.com/1.1/statuses/user_timeline.json

I just can no longer access the oauth/request_token endpoint.

I am frustrated as I can duplicate this using the twitter console but I do not where to turn for help?

Any help would be appreciated.