Using Reverse Auth error


#1

I tried to use the example at https://github.com/seancook/TWReverseAuthExample.

However, I get as a response:

Client is not permitted to perform this action ```

Why is it?

I correctly set the consumer key and secret, and I understood that it’s enabled by default by https://dev.twitter.com/docs/ios/using-reverse-auth


#2
  1. The local account instance may need refreshing. Try removing the Twitter account from Settings.app and re-adding it (this works on both the device and Simulator).

  2. Check to make sure that your iOS device or local machine’s clock is set correctly. OAuth signing requires it.

  3. If you’re running this in a Simulator, I recommend using a version 6.0+, as some devs have experienced problems with the older 5.0 simulators.

I pushed an update to my example that includes some simple logging-- try running the updated example and see if it any of the log output points you at the cause.


#3

Thanks.

  1. I removed the application
  2. I removed Twitter app
  3. I removed the account from settings

However, now I get You were not granted access to the Twitter accounts.

  1. Why do I get it?
  2. What if I don’t have an account on the twitter iphone, but on the web ? for instance, in facebook it would calculate if to open the app or a web page.

#4

i got same error