Users/lookup problem


#1

Hello,

today I have tried to send authenticated GET request to /1.1/users/lookup.json API endpoint and I always get

{ errors: [ { message: ‘Sorry, that page does not exist’, code: 34 } ] }

I have tried with version 1 and get same response.

Somebody have same issue?


#2

Have you verified whether the user IDs you’re sending to users/lookup belong to users that exist? Can you share an example URL you’re executing?


#3

Yes, you are right…

I was testing with random user IDs…

Error message confused me. Its not saying that user id not exists.

Thanks @episod


#4

one more question… Does this api endpoint working only for users that are friends to authenticated user?

Example:
Authenticated user friedns IDs: 1, 2, 3
If I look for user.json?user_id=55, I will get 404?


#5

You do not need to be “friends” with a user to look them up with this method.


#6

Why then I getting 404 responses with body:

{ errors: [ { message: ‘Sorry, that page does not exist’, code: 34 } ] }

for some user ID (that exists)?


#7

Could you give me a concrete example?


#8

Here is example:

GET request: /1.1/users/lookup.json?user_id=274060865

Response StatusCode: 404
Response Body:
{ errors: [ { message: ‘Sorry, that page does not exist’, code: 34 } ] }


#9

Actually, i’m having the exact same issue. After converting to 1.1 my users/lookup call is not working at all.

https://api.twitter.com/1.1/users/lookup.json

Is this a known problem?


#10

In this case, the user is suspended. They may “exist” at another date and time.


#11

Verify the comma encoding you use and ensure that your OAuth library is doing the right thing. If you think what you’re doing is right, please share the POST body and/or querystring you’re using along with the signature base string.

Thanks!


#12

Yes its true…

Thanks for reply