Users in India can't see twitter timeline integrated in iOS App

ios
swift

#1

My users are facing a strange issue - they can’t see the timeline (just a blank page) in India, whereas users in North America and elsewhere are facing no issues at all. Not sure what is wrong. Any help ASAP would be greatly appreciated.

Timeline is shown on my device and simulator but not on user’s devices - this topic has been closed and no resolution. I’ve tried https://twittercommunity.com/t/ssl-connection-warning-in-xcode-7-beta-4-in-regards-to-updating/47703/4 and it doesn’t help at all.


#2

Hey @mhmmdmz,

Thanks for reaching out on this. Are you able to reproduce this locally at all?


#3

No :frowning: all they see is a blank screen


#4

It’s going to be tough to figure out without being able to reproduce this. Are there any common threads in that does the user have ad-blockers installed, have parental controls enabled, or are slower networks?


#5

Slower … not really, I’ve got feedback from users in Sharjah as well as Bombay. They experience the same issue.

I have tried hard to reproduce this but I’m not sure how exactly I could go about doing this.


#6

The only thing I can think might be a slow network where it’s taking a longer time to load tweets in which case you could add a loading screen until you start getting results back from the call to display tweets.


#7

I’m pretty sure a slow network isn’t the issue as the rest of the app loads pretty well. Moreover, the issue is seen in different parts of India as well UAE (where the network speeds are fine). Tested even on WiFi.