Upgrade from v1 to v1.1 "could not authenticate you" status/update


#1

I’ve updated from version 1 to 1.1 and I am getting the following error:
{“errors”:[{“message”:“Could not authenticate you”,“code”:32}]}

I have just double checked the code that I use to create my header and param using: http://oauth.googlecode.com/svn/code/javascript/example/signature.html (only the signature is url encoded as it should be)

I am sending the same values in my post function:



But for some reason it won’t authenticate. besides checking that my header/signature are correct as per above link. what else do i need to check? Why would it suddenly break between versions. its not oauth that has changed.


#2

I was looking at the wrong section. The status wasn’t urlencoded. this seemed to work in the old version but not the new.


#3

Yes, the API is becoming stricter generally in overall HTTP and OAuth correctness.