Update: 429 troubles


#1

We have about 15 test twitter accounts. For 2 of them, calls to the user_timeline API (with user auth, not app auth) always get a 429 rate limit error. These two accounts were both normal, personal twitter accounts that had used Twitter on iOS and on a desktop client successfully.

We are making only a few attempts on the user_timeline call in each 15 minute window, far below the documented rate limit.

We have tried making no calls for 15 minutes to re-set the window, and the next call we make still returns error 429 for these accounts.

Our 13 or so other Twitter accounts do not have this problem. I have checked the return header and the calls-remaining value is sane.

We checked the Twitter call stats for the 2 problem accounts. The user_timeline call returned a calls-remaining value of 180. Oddly, the statuses/friends call returns a calls-remaining value of 0, despite us never making that call.

We revoked access to our app from one of the problem accounts. We authorized our app again and the first call to user_timeline succeeded. The second (and subsequent) call(s) got error 429.

I have tried searching these forums for answers, but the only solution I found to a similar problem was (https://twittercommunity.com/t/problem-hitting-immediate-rate-limit-max-on-ios-with-social-framework-http-status-429-rate-limit-exceeded-code-88/13003) “[delete] the system setting for my Twitter account and [sign] in again”.

We thought other apps attached to those accounts may be somehow affecting the rate limit of our app, so we de-authroized iOS and other authorized apps from those accounts. This did not help.

Any aid in identifying or fixing this problem would be appreciated.

Thanks,

KwiltApp


#2

It turns out we were infinite looping (whoops!) under certain circumstances, which used up all our rate limit. We solved the problem on our end and look forward to enjoying successful Twitter calls in the future.