Unchecking "Include Media" doesn't seem to be working on embedded tweets


#1

Over the past week or so, if I attempt to embed a tweet that has media with it, the media is included in the embedded tweet even if I uncheck the “Include Media” checkbox. For example, I’ve been trying to embed the following tweet this morning: https://twitter.com/harrypav/statuses/399237299679944704. I click on “More” and then “Embed Tweet”. When the tweet pops up, I uncheck “Include media” and the media disappears. I then copy and paste the HTML. When I preview my post, the media is in the embedded tweet.

I am using an up to date Chrome on MAC OS X (30.0.1599.101) and replicated on Firefox as well (24.0).


#2

Thanks for reporting the bug.
Until we get this fixed, to hide the media, add by hand data-cards=“hidden” to the blockquote tag generated, as described in the “Controlling Tweet Display” section of https://dev.twitter.com/docs/embedded-tweets. So, in the case of the tweet you mentioned:

I'm declaring this a must read for baseball analysts http://t.co/gchFBftIJ0

— Harry Pavlidis (@harrypav) November 9, 2013
becomes:

I'm declaring this a must read for baseball analysts http://t.co/gchFBftIJ0

— Harry Pavlidis (@harrypav) November 9, 2013

#3

Vincent,

When trying to capture a twitter feed I have experienced the same problem - the html os copied direct from the website - I checked remove images and it works on the site, but when I copy and paste the html it shows the images. data-cards=“hidden” does not work - can you help as I would only like the text.


#4

data-cards=“hidden” is only for embedded tweets.
For embedded timelines, showing or not images is controlled by a checkbox on the widgets settings screen of your widget https://twitter.com/settings/widgets
Note that changes to the settings take a few minutes to be applied.


#5

#6