Unable to validate my site, always got internal error


#1

Hi

I want to validate my site (it works before).
But I always got 'Internal Error. Try again later’
The same time I try to validate other site with twitter card.
The function is fine. But not work on my site.
Please help me find what’s the problem, thanks.

Example URL: https://blog.othree.net/log/2013/12/21/ipad-air/


#2

More survey on this issue:

I fount if I use bit.ly to shorten the url.
Validator will not have error.
But still fails if I paste the url directly.

And some link on my site also works without bit.ly’s help:

Almost every single article’s link fail and need bit.ly to help.


#3

The Twitter Card may have one or more of the following issues:

The summary_large_image Card type is not whitelisted. Please submit for approval via the validator at https://dev.twitter.com/docs/cards/validation/validator.
A robots.txt file was not accessible to verify access to images/videos. (http://farm8.staticflickr.com/robots.txt)


#4

Thanks, I change summary_large_image back to summary.
I want to apply the new card type so I change the value to summary_large_image.

The issue still happens.
I don’t think its related to robots.txt on flickr.
The strange part is:
If I try https://blog.othree.net/log/2013/12/28/2013/
It fails.
But if I try http://bit.ly/1h3S9M6 (bit.ly shorten url of the above url)
It works.


#5

I am having a similar issue. I have all of the meta tags for summary cards installed but I get timeout errors and internal server errors every time I try to validate. I’ve validated cards for several other sites without issue, so I am not sure why I am having a problem with this one?


#6

I found out why.

I apply 'https://blog.othree.net/log/2013/12/28/2013/'
But the bot access ‘https://blog.othree.net/log/2013/12/28/2013

Compare:

https://blog.othree.net/log/2013/12/28/2013/ https://blog.othree.net/log/2013/12/28/2013

The last slash is missing…


#7

Can you provide a URL?

Thanks!


#8

Looks like you’re OK now. Let us know how we can help!


#9

I think there are 2 way can help

  1. Not modify the URL from user, I know there is security issues need to care. And I think my case is just a bug.
  2. My server give 404 header back to bot. If the error message include this information. Will much helpful.

#10

Same error message: ""Fetching the page failed due to an internal error."
URL: http://www.kockamania.hu/Termekek/LEGO-4440-Erdei-rendorkapitanysag?id=543
Thanks!


#11

Could you please remove the Twitterbot “Disallow” directive entirely from your robots.txt file? You should then be able to validate your Twitter Cards. Thanks!


#12

Thanks! Removed!
Results:
I got this about 30 times: "Fetching the page failed due to an internal error."
I got this about 2 times: "exceeded 15.seconds to image-proxy while waiting for a response for the request, including retries (if applicable)"
I got this about 1 times: “small image”


#13

Works! “approval pending” Thanks!


#14

How this problem going?
I also need the following help.
> 1. Not modify the URL from user, I know there is security issues need to care. And I think my case is just a bug.