Unable to upload .MP4 file

media
video

#1

Hi there,

I’ve been following threads like these very very closely, but I’ve exhausted my knowledge on what might be going on here. I cannot seem to get a perfectly fine .mp4 uploaded anymore — earlier tests worked fine.

Details:
Codec is avc1
640x360 resolution
748kb
~12 seconds long
24 fps
Video bitrate is 494 kb/s
Audio bitrate is 64 kb/s
Audio is in stereo

I get the following response:

{ request: '/1.1/media/upload.json',
  error: 'Invalid media: fail: [decode/mp4.cpp: finish_initialization (68)] internal inconsistency: "!(summary)" condition failed, Reason: Some(InvalidContent).' }

This “decode/mp4.cpp” bit makes me wonder if there’s still something wrong with the file. Any ideas?


#2

Also not working with either mpeg4 or libxvid for video, and aac for audio. Any thoughts?


#3

I was having the same issue with a different error message: “Invalid media: fail: [decode/mp4.cpp: MP4 (341)] uninitialized: “true” condition failed, Reason: Some(InvalidContent).”

I was able to find that mp4s from gfycat wouldn’t work but if I downloaded a test mp4 directly from Twitter it worked. I’d suggest trying to save the MP4 a different way.


#4

I personally encounter this issue with almost all the videos I tried to upload. To solve the problem I have been recording a video with my phone and the following configuration:

  • 30 fps
  • resolution : 1280x720
  • duration : 4 seconds
  • size : 7MB
  • sound : stereo (48kHz)

None of the other video I tried worked. Also be careful that the sound needs to be mono or stereo.


/media/upload rejecting mp4 videos
#5

You need to convert to H.264 Video
can do here here
Cardiffdir