Unable to submit app due to MoPub issue


#1

Hi,

The latest MoPub installed via Fabric plugin is causing the exact same error as described here:

https://code.google.com/p/gmaps-api-issues/issues/detail?id=8568

In short, there are values in the MoPub bundle plist (CFBundleSupportedPlatforms) that are causing itunes connect to reject the app upload outright.

Please update the plugin asap.

Thanks


#2

Hello wapo_y_wapa!

Can you confirm if you are building your app with bitcode and share the exact errors you are seeing with support@mopub.com?

We want to make sure that we can track down a possible issue that will affect our Fabric users.

Thanks!


#3

Hey,

Thanks for the reply. Due to another issue I was having, I uninstalled fabric and migrated to fabric via cocoapods … after this, submitting to Apple worked fine.

Thanks!


#4

I’m seeing this issue as well. Using non-CocoaPods Fabric.

https://dl.dropboxusercontent.com/u/2758349/Screen%20Shot%202015-11-09%20at%2012.38.13%20PM.png

I cannot enable bitcode because of another compiled library I’m using that doesn’t support it.

It looks like I could just edit this info.plist file…

https://dl.dropboxusercontent.com/u/2758349/Screen%20Shot%202015-11-09%20at%2012.58.19%20PM.png


#5

I tried deleting these keys in the MoPub info.plist file and the submission worked.

CFBundleExecutable (also called simply "Executable file")
CFBundleSupportedPlatforms

Not sure if MoPub still works now but I suspect it does.


#6

Thanks for reporting this issue! We are looking into it now and should have it resolved this week. For any additional questions, feel free to reach out at support@mopub.com


#7

This worked for us, thanks!

@autojoechen Any updates on this issue? Are there any adverse affects in removing the CFBundeExecutable and CFBundleSupportPlatforms keys?