Unable to request approval from twitter cards. "Request Approval" link greyed out


#1

HI earlier today i tried to request approal for twitter cards and it worked for my blog link which is http://caghanemirzade.com/blog/2014/06/videolarimi-youtubea-yuekleyip-facebook-uzerinden-mi-yoksa-direk-mi-paylasayim/

but i wanted to do it for the whole website. Now when i try to validate for my link “caghanemirzade.com” the “Request Approval” button is greyed out and it indicates “*.caghanemirzade.com not approved”

my OG tags are all ok i have green boxes on all of them.

Any help or feedback is appreciated.


#2

I have the same issue with the greyed out “Request Approval” button.


#3

Ok i came to tell you guys how i fixed my problem. my twitter card was set to “gallery” and somehow it wasn’t retrieving the photos although the Twitter:img 1 -2 -3 was showing green. i switched from Twitter card “gallery” to "summary large image and it worked so i could validate it


#4

Thanks for updating here.

To clarify, we associate the card with the entire *.site.com domain, so you don’t need to worry about specific pages.