Unable to render card preview


#1

I have been unable to get my cards to validate. I am using the Yoast Wordpress SEO plugin. All meta tags are present in the source code, but the validator continually fails.

Sometimes I just get the message “Unable to render Card preview” but usually it is accompanied by a log message “ERROR: FetchError:exceeded 4.seconds to Portal.Pink-constructor-safecore while waiting for a response for the request, including retries (if applicable) (Card error)”.

That’s very similar to the message in the troubleshooting documentation, “exceeded 15.seconds to pink-floyd while waiting for a response for the request, including retries (if applicable)”, although not exactly the same. I have reviewed the troubleshooting steps and have made sure that the robots.txt and .htaccess files are set up properly to allow access.

What else am I doing wrong?

An example post is http://blogs.angelo.edu/2015/01/06/preparing-gre/.


#2

Also, I checked with my web host to make sure that none of the twitter IPs were blocked, and they are not.


#3

Another update. We have been intermittently able to get the page to validate today, and submitted for approval. But every time, we get a message back that it was rejected because it could not be validated. I assume because it is intermittent, even though we can sometimes get it to validate, it does not validate when Twitter tries.

What else can we do?


#4

I have been facing the same exact issue. Same error as well. We have been facing this for about two weeks and it is intermittent also. Occasionally, a card will validate, but it is not consistent.


#5

I think I have fixed my issue. I started looking at page load times, which were normally in the 1-2 second range, but occasionally in the 3-4 second range. The biggest offenders seemed to be some custom web fonts. I removed the fonts from the site temporarily and the card validated. I also got an approval almost instantly.


#6

@jon_wilcox thanks for the update, and sorry again for the inconvenience this caused you. Appreciate you taking the time to both work through the issue, and let us know what fixed it for you.


#7

I think the error message could be more helpful. The clue was in the error “exceeded 4.seconds to Portal.Pink-constructor-safecore”. The problem was, I was rarely seeing 4+ second load times so that error didn’t make sense to me. And the troubleshooting didn’t say anything about optimizing load times. Obviously optimizing a site is a good thing to do anyway, but if Twitter is going to reject sites that exceed 4 seconds, the error message should indicate that. I’m glad I got it working though.


#8

That’s really great feedback, and I appreciate it. I’ll work with the team on improving the troubleshooting docs.


#9

Even though we have now been approved, I am having problems with cards actually showing up in my tweets. I can tweet links to posts on the blog and sometimes a card shows up and sometimes it doesn’t. For example, last time I tried this link, it worked - http://blogs.angelo.edu/2015/01/06/preparing-gre/. But I can not get this one to work - http://blogs.angelo.edu/2015/01/10/refuting-reasons-putting-off-college/.


#10

I’ve the same issue and I can’t solve. Even optimizing the site, I can’t render card preview.


#11

I discovered that the problem is the fact that I use a ddns service (noip.com) and I can’t understand how to solve the problem.


#12

I have the same problem with domain upcr.cz
robots.txt - clear
.htaccess - clear
vps hosting - no IP block
DNS provider - no IP block
I checked card validator many times, but access logs are free of something like “Twitterbot”, or Twitterbot IP´s.


#13

The problem is Google webfonts loaded on the website.

When we removed this API calls, card is successfully validated.

Is this problem on Twitter side, or on Google servers?

Typekit.com webfonts works without a problem.