Unable to render Card preview > ERROR: Fetching the page failed because other errors


#1

Description of issue:

Posts from my site are not utilizing Twitter cards when I link them in my tweets, and the validator is throwing the “because other errors” error. I tried registering a brand new domain and duplicating the site content today. The new (but identical) site posts all validate and tweet fine. But the original still doesn’t work.

When I was preparing links for this topic, somehow - inexplicably - one of the posts validated fine! I checked the rest of the posts, which all continued to throw the same “other errors” error. And when I came back and re-checked the one good post, it had reverted back to being broken. See my screenshot images for the proof. But it seemed to be working … for less than 60 seconds.


URL affected (must be public):

https://6ydbox.com/karl-spratt-new-england-revolution/ [validator unable to render]
https://227scottlane.com/karl-spratt-new-england-revolution/ [duplicate of 6ydbox; validator working fine!]

Troubleshooting steps attempted [note that we will not prioritise posts unless there is evidence of following the troubleshooting guides]:

Twitter meta tags showing up in the source. (and meta tags match those on 227scottlane.com)
Twitterbot access seems fine(?) - the robots.txt file mirrors the working 227scottlane.com version
I’m using the Yoast SEO plugin on both domains
Tried top-level site URL in the validator
Using supported card types

Thanks for any help!!!


#2

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.