Unable to recreate my access token


#1

I have been trying this for a couple of days. When I go to the details tab for any of my applications at dev.twitter.com and click the “Recreate my access token” button, the access token and access token secret do not change. I have tried this in Chrome and FF, and waited several hours each time. These two values are still unchanged. Any ideas how to change these tokens?


#2

Strange. Are you able to generate a new one by using the standard OAuth flow to accomplish it?

When did you begin trying these steps? What’s the consumer key?

Thanks


#3

Additionally, are you able to still use that access token with the values provided?


#4

The original tokens still show up as valid when used with /account/verify_credentials or other API calls.

I have not tried requesting new tokens through OAuth. I am using these tokens to document single-user OAuth, so they were created using the dev.twitter.com UI.

The consumer key for this app is m6oeHBbFqUk3gvfVbnjiw.

The access tokens were created with an earlier consumer key. When I couldn’t change the access tokens, I reset the consumer key and secret through the dev.twitter.com UI. These values changed, but the access tokens did not. I am now testing with the new consumer key and secret. These work with the original access token and secret. I feel pretty confident that my test code is correct, since changing any of these tokens in the code causes verify_credentials to return a 401.


#5

Thanks Adam, looking into this. In the meantime, you probably can mitigate the issue by explicitly revoking the token from https://twitter.com/settings/applications and/or forcing a transit between permission levels.


#6

I am having a the same problem. I cannot recreate my AccessToken. Does anyone knows of a solution to this issue yet? Thanks!


#7

I had the same problem too until I found the solution.

  1. Revoke access to your application on https://twitter.com/settings/applications as mention by @episod.
  2. Return to your application’s page on Twitter (https://apps.twitter.com/app//keys).
  3. Click on “regenerate my access token”.
    Twitter will prompt you to create a new one since you have revoke it on step 1.

#8

Hi…

It seems this issue is happening again…

Tried everything above and on the other threads… Revoked… Undo revoked… Recreated…

Not able to regenerate my token. Please help!

My API key is LjKybfUOgf6eTOv0nwdTNAM3Q

Thanks in advance…


#9

Having the same problem here - I’ve tried revoking, re-authenticating, deleting, recreating, etc. - clicking the “create my access token” button gives a positive confirmation, but then nothing gets generated, and the text says “You haven’t authorized this application for your own account yet” even though the app does show up as authorized on my twitter account.

any help would be appreciated. thanks!


#10

Hi again,

This is weird…

Although waited for days it didn’t change it. Last night I decided to give a last try… I’ve changed my permissions as well. This morning seems my token is also changed.

Now I will wait for another day to change my permission back :slight_smile:

Hope it will change it.

Thank you.


#11

Same problem - I revoking, re-authenticating, deleting, recreating. - click “create my access token” button gives a confirmation, but nothing, and the text says “You haven’t authorized this application for your own account yet” even though the app does show up as authorized on my twitter account.

help be appreciated. thanks!


#12

We are aware of the issue with tokens not updating on https://apps.twitter.com. We are actively working on fixing the problem. The actual values are updated but due to a cache issue the display is not.

Tracked in https://dev.twitter.com/issues/1653, follow there (and subscribe) for updates.


#13

Fixed now, https://dev.twitter.com/issues/1653 updated.


#14

Thanks, did this and fixed the problem I had too!


#15

This issue is happening for me as of today, the new tokens are never shown when regenerated. Has the same caching issue occurred again, or is this a new cause?


#16

Mee too! Today I had the same issue.
I create the token, it works for about 1 hour, after a receive auth error and on the app page the token is disappeared.


#17

This happened to me today. Fixed by changing the permissions on the app to read write and then back to what I need, read write and DM access