Unable to post image via API v1.1

media
api

#1

Hi,
So we’ve been experiencing some issues in updating status with images.

Here’s the image we tried to publish:

And here’s the response:

The size of this image is fine do don’t really know why it failed.

Thanks in advance!


#2

Was the image uploaded in one go or using the chunked API? If the latter, did you check that the image was successfully processed (STATUS command)?


#3

So we used media api (https://upload.twitter.com/1.1/media/upload.json) to upload that image - status code returned is 200 and we did get back the media id.

I just tried upload this image again and it’s a success.

{media_id=885309483978706945, media_id_string=885309483978706945, size=1075713, expires_after_secs=86400, image={image_type=image/png, w=2500, h=1308}}

Then i used this media id in status update it failed again.


#4

@andypiper
hi,I face the same issue. I upload media like this:

But, when I use the media_id for this. It return"twitter_ads.error.NotFound: <NotFound object at 0x7ff0a6797b88 code=404 details=[{‘message’: ‘939119381551943680 was not found’, ‘parameter’: ‘wide_app_image_media_id’, ‘code’: ‘NOT_FOUND’}]>"

Can you help me?


#5

@andypiper The python sdk is wrong? Because it’s fine before.


#6

Since you’re using the Ads SDK I would recommend asking in the Ads API SDK category.


#7

@andypiper
Thank you. I did this. Here is the new url