Unable to make auth login with iPhone application


#1

I have an application which uses REST API heavily.
For last one week we get reports from iPhone users.
Steps like this:

1- User opens Twitter iPhone app and find our application’s link.
2- User clicks link, Twitter app opens our website inside Twitter browser.
3- User clicks sign in with twitter, writes username password.
4- user gets a page. That page says that “@sessions doesnt exists” and shows empty profile page who’s username is @session.

Why this happens ? How can we solve this ?

Note: Everything works fine for others. This happens in minority of iPhone users.


#2

These are the screenshots for the oauth login amd error.


#3

Similar problem with @sessions is here: https://dev.twitter.com/discussions/30392


#4

This authentication error is not yet resolved. I think twitter should fix this bug as soon as possible.


#5

We are investigating.


#6

Thank you.
I checked this issue with another Twitter application, same problem exists there also.


#7

These are some erroneous applications’ user agents:

  • Mozilla/5.0 (iPad; CPU OS 7_1_2 like Mac OS X) AppleWebKit/537.51.2 (KHTML, like Gecko) Mobile/11D257 Twitter for iPhone
  • Mozilla/5.0 (iPhone; CPU iPhone OS 7_1_2 like Mac OS X) AppleWebKit/537.51.2 (KHTML, like Gecko) Mobile/11D257 Twitter for iPhone
  • Mozilla/5.0 (iPhone; CPU iPhone OS 7_1_1 like Mac OS X) AppleWebKit/537.51.2 (KHTML, like Gecko) Mobile/11D201 Twitter for iPhone
  • Mozilla/5.0 (iPad; CPU OS 6_1_2 like Mac OS X) AppleWebKit/536.26 (KHTML, like Gecko) Mobile/10B146 Twitter for iPhone

#8

thanks for the additional detail - we are taking a look right now.


#9

@andypiper to add on to this, I am also currently dealing with this issue. I found a post that points out to other people having issues in this topic. https://dev.twitter.com/discussions/33024

Would love to hear any feedback on this issue and if there are any other suggestions as to how to deal with this for the meantime.


#10

We are working on a fix for this - stay tuned and we really do apologise for the inconvenience it is causing.


#11

Thank you for the quick response. Any estimate idea as to when this can be resolved?


#12

I’ll use the word “imminent” - hopefully in the next day or so but it may take longer depending on backend deployments.


#13

@andypiper the authentication process doesn’t redirect anymore to @sessions. I have tried it a while ago. I think this issue’s now solved.


#14

Seems to be working correctly again for me


#15

Great news - yes, we rolled out a fix yesterday - glad things are working again for you all!


#16

Thank you. It seems working again.