Unable to add image to my Lead generation card


#1

Hi.
I have used twitter cards before, but quite new to the lead generation card. This is my first time and I have all the required files to create a Lead generation card. The problem is unable to upload my twitter card image. I get “Error while uploading images.” when I try.

Tried doing it last night and 12 hours later too. No improvement yet. Any help is appreciated.

Koushik


#2

I´ve got the same problem :(.


#3

What size (dimensions and file size) are the images you are trying to upload?


#4

I tried 2 sizes. 800x200px and 1000x250px.


#5

same here, unable to add image. gives error : Error while uploading image.


#6

Was this problem ever solved? I have it too.


#7

I’m having this issue as well. Is there a way to work around it?

I’ve tried multiple images, multiple sizes.

No dice.

It loads for a while before giving me an error message.

Anyone figure this out?


#8

Try deactivating any ad blockers you have - that worked for me.


#9

Me too! All I had to do was open Twitter in incognito mode (which turns off extensions, including ad blockers), and it worked instantly.

Thanks!