Twurl /followers/ids returns wrong followers



I execute the following command from the command line:

twurl “cursor=-1&screen_name=FOREXcom&count=5000” /1.1/followers/ids.json

Instead of returning the first 5000 followers of forexcom, it returns MY followers. I have sliced and diced this every which way with no success.

  1. Could someone please try to execute this and see if they get the same result?

  2. Is there anything wrong with my command, or is this a bug?

Many thanks

Ubuntu 14.4


I think your query parameters are being ignored as you’ve not appended them to the base URL.

Try this:

twurl "/1.1/followers/ids.json?cursor=-1&screen_name=FOREXcom&count=5000"


Thank you Andy! That worked. Is there a central are where twurl is explained? It seems there are bits here and there. I based by (wrong) query on the media upload example. I suspect that it is the correct form for POSTs, but not for GETs. In any event, thanks again. I am no longer dependent upon the perl Twitter library.


Well, that format of command is nearly correct for POST - you’re missing a -d parameter ahead of your post data.

twurl -T gives you a short tutorial, and otherwise you can check the README which is mostly the same. There’s a short, also similar, set of examples in the Ads API forum, too.