TWTRComposer dismisses automatically within 15 seconds

fabric

#1

Hi,
I am using the the latest Twitter 2.4.0 provided by Fabric. The TWTRComposer dismisses automatically within 15 seconds after being presented, with the following log in the console:

[1598:207673] plugin com.apple.share.Twitter.post interrupted
[1598:207084] plugin com.apple.share.Twitter.post invalidated
[1598:206158] viewServiceDidTerminateWithError:: Error Domain=_UIViewServiceInterfaceErrorDomain Code=3 “(null)” UserInfo={Message=Service Connection Interrupted}
[1598:206158] Tweet composition cancelled.

This is how the TWTRComposer is presented:

            TWTRComposer *composer = [[TWTRComposer alloc] init];
            [composer setText:trimmedText];
            [composer setURL:[NSURL URLWithString:@"http://movies.ndtv.com/bollywood/shah-rukh-khan-is-prisma-perfect-see-what-he-shared-on-instagram-1440933"]];

            [composer showFromViewController:APP_DELEGATE.viewController completion:^(TWTRComposerResult result) {
                NSString *msg,*msgTitle;
                if (result == TWTRComposerResultCancelled) {
                    NSLog(@"Tweet composition cancelled");
                }
                else {
                    NSLog(@"Sending Tweet!");
                    
                }
            }];

#2

Thanks for reporting this @awaazrobo, I haven’t been able to reproduce this yet. If you switch to Twitter 2.3.0 does it happen or in a sample project?

If you’d be willing to share more of your code where you’re presenting TWTRComposer that might also help me repro it or figure out what’s happening.

-Mike


#3

I had the same problem sharing an NSURL from the UIActivityViewController instead of TWTRComposer. I passed the absoluteString of the NSURL instead of the NSURL and it worked. It is not the exact same problem, but maybe this will help you.


#4

Hello Mike Thanks for your response. Yes I am using the latest Twitter 2.4.0, . This is not happening in simulator, but happens in device.

Steps to Reproduce:
1)Open the attached sample app.
2)Tap on “Share The News” button, which will present the tweet composer.
3)Wait for 15- 30 seconds, without tapping on anything in the app.
4) The tweet composer gets dismissed automatically

Expected Results:
The tweet composer should not dismiss unless we tap on cancel or post button on the tweet composer.

Actual Results:
In most cases tweet composer dismisses automatically without any user response

Version:
iOS 9.0 , iOS 9.3.3

Notes:
This can be reproduces 3 out of 5 times

Configuration:
iPhone 5c 16GB, using Wifi


#5

Thanks for the reply , but absolute string is not solving my issue.


#6

Thanks @awaazrobo - I’m not seeing the attachment unfortunately. Can you resend the link?

-Mike


#7

Hai mike,
Pls find the link of the sample app. The steps mentioned above will replicate the issue:

Thanks


#8

Is there any update on this issue? I am seeing similar… The composer dismisses after a nunber of seconds.
Sharing a string works. Sharing an NSURL causes the issue to occur.


#9

We’re seeing the same issue. TWTRComposer() closes 2-3 seconds after .show() when sharing a url.

Worth noting it works the FIRST time you try to share a specific url. But if you try to share the same url again we see the issue.


#10

I’m having this issue too. I’m not technically using TwitterKit, I’m just using the system UIActivityViewController. But if I try to share a url to Twitter, I have the same result as the others, above. Note that if I test my link using Twitter’s Card Validator (https://cards-dev.twitter.com/validator) it works as expected. I’ll paste the relevant logs here:

[core] Finished setting up remote view controller
[core] SLRemoteComposeViewController: (this may be harmless) viewServiceDidTerminateWithError: Error ll)" UserInfo={Message=Service Connection Interrupted}
viewServiceDidTerminateWithError:: Error Domain=_UIViewServiceInterfaceErrorDomain Code=3 "(null)" 
[core] SLComposeViewController remoteViewController: <SLRemoteComposeViewController: 0x102029c00> didTerminateWithError: 3 "(null)" UserInfo={Message=Service Connection Interrupted}
[core] SLComposeViewController completeWithResult: 0
[core] SLComposeViewController skipping explicit dismiss because isBeingDismissed is already 1
[core] SLComposeViewController dealloc <SLComposeViewController: 0x101df18f0>

This is under iOS 10.3.1, any device: apparently this issue has persisted for quite a long time. Has any workaround emerged, after all this time?