TWTRComposer - Cancel & Tweet buttons invisible

ios
xcode
twitterkit

#1

Cancel and Tweet buttons missing using newest TwitterKit 3.1 for iOS.03 PM

Although the buttons are invisible, if you click where they ‘should’ be, they are there. Of course, a user would never know to even try this.

The buttons are visible in another App we have using same exact implementation… but for some reason both buttons are missing in this app.

Please help


#2

Hi @dwdev,

Can you confirm that you also added the necessary bundle files (TwitterKitResources.bundle and TwitterShareExtensionUIResources.bundle)? Adding these to your XCode project should fix the problem.


#3

Thank you for the reply. Yes, the resource bundles are added to the project & target. The only difference between our other app that this works fine is, is that other project uses cocoa pods… This project uses manual SDK implementations.

I have checked and double checked that everything was added correctly. And everything works, except the cancel and tweet button appearance. I thought about the resource bundles being the issue… but am unsure on how to find the missing link, as everything seems to be linked up correctly.


#4

Hey @dwdev

Is the issue specific to a device size (iPhone 5 vs 6 vs 6 Plus)? Do you mind also letting me know what language your device is in?


#5

This is with an iPhone 7+. Language is english.

What I have tried so far:

  1. Manually added the resource bundle files to the ‘Copy Bundle Resources’ section in ‘Build Phases’ for the target.
  2. Manually added TwitterCore and TwitterKit frameworks to ‘Link Binary with Libraries’ section.
  3. Added the localization tags from the embedded resources file’s en.lproj Localization.strings file to our main Localization.strings file.

Nothing has helped. Also, this happens when building with either Xcode 8.3 & xcode 9.

The only thing I can think is it has something to do with installing the SDK manually without pods. Pods is not an option for us on this project, however.


#6

Also just tested on iPhone 6 with iOS10.3 installed. Same result.


#7

Hi there. Any idea on this? We’re stuck.


#8

Hey @dwdev I’m trying to reproduce this too. I’ll ping you here if I’m able to reproduce your issue :slight_smile:


#9

I have same problem.
and i found text color of button is white.
maybe navigation bar tint color?


#10

This is also happening in the share extension. Our app uses dark navigation bars with white status bar text, this might be what triggers the buttons in the share extension to become white.


#11

Nice! This was it. We have added a workaround for the time being.

the fix was getting rid of this…

[[UIBarButtonItem appearanceWhenContainedIn:[UINavigationBar class], nil] setTitleTextAttributes:[NSDictionary dictionaryWithObjectsAndKeys:[UIColor whiteColor], UITextAttributeTextColor,nil] forState:UIControlStateNormal];

#12

Been away guys & my apologies for that.!!


#13

Hi I am Also stuck with the same as I could able to see the button on my Iphone 8