Two tweets when using Tweet button


#1

Hi guys,
I am using Twitter button on my page. When I click on it to share a page I get share window with predefined text and url of my choice, which is expected. However when I click “Tweet” I get another window similar to previous one. The text is the same but the url is missing. When I tweet this I am finally redirected to final screen. Of course on my profile there are two tweets.
I was able to reproduce this issue on other sites as well. This was however not deterministic as on some sites the button worked as expected (showing only one tweet screen) and on others it worked in mixed mode (one Tweet button worked good and another showed two tweet screens). This however was not the case after removing cookies when all sites started to show additional step when tweeting their contents.
Any help on how this can be solved will be more than appreciated.
Thanks in advance.
Simon


#2

Same problem here. Any help?


#3

I’m seeing the exact same thing. This is even the behavior that I am seeing on Twitter’s own tweet button builder when you click the tweet button to test it out.

I’m seeing the problem in both Chrome and Firefox on Mac OS X Lion, I have not done exhaustive testing across multiple platforms, but this needs some attention, because it is definitely not working properly.

In the meantime, if anyone has a workaround, I would greatly appreciate it. I’ve tried adding an onclick return false to the button link (I thought that perhaps an event was firing twice, but no luck).

Any chance that the whole Intent thing is screwing this up somehow?


#4

I’ve been able to confirm this behavior in Safari as well, and I’m seeing it pretty much anywhere there is a Tweet button.

I can’t believe this isn’t getting more attention!


#5

Does anyone have a live URL which reproduces this?


#6

http://twitter.com/about/resources/tweetbutton

Test using horizontal count, text of ‘Test Tweet’ and URL of http://www.test.com - the button at the bottom left of the page (the test button) displays this behavior.

Of course, every other Tweet button out there displays the exact same behavior as well.


#7

Unfortunately I’m unable to reproduce. Is there any commonality between the browsers you’re using to test? Ad blockers, third party plugins, etc?


#8

I’ve tested on Chrome, Firefox and Safari (all latest versions, running on Mac OSX Lion).

I’ve also tested on Chrome, Firefox and IE 8 on Windows 7.

None of the browsers has much in the way of plugins, but the Chrome and IE8 on my Windows machine are 100% vanilla, and the machine isn’t running anything out of the ordinary (standard install, plus Microsoft Security Essentials).

Pretty sure it isn’t unique to my browsers, but with you not being able to replicate, I am wondering if it is Internet/router/DNS related somehow.

I’m on Xfinity but using Google’s DNS because Xfinity/Comcast DNS is terrible. I’ll try to replicate from the Starbucks down the way and see if I get the same behavior.


#9

OK - I’ve ruled out DNS and ISP. I’ve also had several associates (some in different states) try this out, and ALL of them are witnessing the same behavior.

Please try this again, because sometimes (less than 10% of the time) it works as expected, but the rest of the time, the incorrect behavior shows up.

Again, to make sure we are talking about the same thing: When the tweet button is pressed, a popup shows up, with preloaded tweet and URL. If someone presses ‘tweet’ on the popup, the window gets replaced with a second tweet window, that has the preloaded text, but not the URL. If the person presses tweet again, there would be two tweets in their timeline (one with link, one without). If they simply kill the window at that point, they will have only one tweet in their timeline, but that is not the correct behavior.


#10

If it helps at all, here is a test implementation that further illustrates the problem: http://www.insolentcat.com/social.php

Note that I am using the example code:

twttr.events.bind(‘tweet’, function(event) {
alert(“tweet occurred”);
});

To pop an alert when the tweet happens. If a second tweet box pops, though, and the user kills it, then the event does not fire.

(Yes, I know that the JS on my page is located below the implementation of the tweet button. It shouldn’t really matter, and I have tested placing it all over, including in the header. I’ll happily relocate it again, though, if you think a specific location would help).


#11

I am also experiencing this problem, has anyone figured a solution or workaround?


#12

Thanks for following up. Unfortunately (for the sake of being able to reproduce) this page works fine for me. We’ll continue to look into this, but if anyone else reading this has this issue please follow up in this thread.


#13

Thank you for double checking - if you don’t mind my asking, what OS/Browser are you using to check? I’d like to try to replicate a configuration that appears to work, and see if that reveals anything.

Also, FWIW, I removed the tweet class (turning it into a regular link), which kills the popup (as expected) and sends the user to a new page to tweet. The thing is that when one tweets there, the page redirects to a second tweet page. This is the same behavior, just not in a popup. To me, this indicates that the problem is purely related to the redirection of that tweet page/form.


#14

just thought i’d chime in again,

I’m having this issue on a website I’m working on as well as the twitter button website and I just was able to replicate it on your testing website you linked above

I’m running Windows 7 with the current version of Chrome


#15

Yeah, a theory is that this may have something to do with the auth tokens for specific accounts, which would explain why it seems to work for me, but not for you.

FWIW, I’m using Chrome Dev/Firefox/Safari on OSX Snow Leopard & Lion.


#16

I’ve been exeriencing this problem since the 4th November.


#17

no one have a solution?


#18

We deployed a fix for this to production. Please let us know if you continue having this issue.


#19

{
“ينسق” : فارغة ،
“مبتورة” : كاذبة ،
“created_at” : “خميس 14 أكتوبر 2010 22:20:15 +0000” ،
“تفضيلا” : كاذبة ،
“الكيانات” : {
“عناوين المواقع” : [
] ،
“hashtags” : [
] ،
“user_mentions” : [
{
“الاسم” : “مات هاريس” ،
“معرف” : 777925 ،
“id_str” : “777925” ،
“مؤشرات” : [
0 ،
14
] ،
“screen_name” : “themattharris”
}
]
} ،
“النص” : “؟ @ themattharris مهلا كيفية الامور” ،
“الشروح” : فارغة ،
“المساهمة” : [
{
“معرف” : 819797 ،
“id_str” : “819797” ،
“screen_name” : “episod”
}
] ،
“معرف” : 12738165059 ،
“id_str” : “12738165059” ،
“retweet_count” : 0 ،
“جيو” : فارغة ،
“ريتويتيد” : كاذبة ،
“in_reply_to_user_id” : 777925 ،
“in_reply_to_user_id_str” : “777925” ،
“in_reply_to_screen_name” : “themattharris” ،
“المستخدم” : {
“معرف” : 6253282 ،
“id_str” : “6253282”
} ،
“مصدر” : “على شبكة الإنترنت” ،
“مكان” : فارغة ،
“in_reply_to_status_id” : 12738040524 ،
“in_reply_to_status_id_str” : “12738040524”
}
]


#20

good