TwitterKitResources.bundle/TwitterCore.framework does not contain a bundle executable

ios
fabric

#1

Hi all,

I tried validate archive for submitting myapp to appstore using fastlane.
I got error following,

"Invalid Bundle. The bundle at 'myapp.app/TwitterKitResources.bundle/TwitterCore.framework' does not contain a bundle executable."

How do we solve it?

Thanks.
Takeshi.


#2

Hey @takecian,

It sounds like you have our SDKs copied into your app’s executable. You only want to link them in.

-Mike


#3

Hi @bonnell,

Thanks for reply.
I’m not sure how to solve, I add TwitterKitResources.bundle into my project with copy box unchecked.
However same error occurred.

Takeshi.


#4

Do you see the framework only in “Link Binary with Libraries” in your Build Phases? It shouldn’t be in “Copy Bundle Resources”.

-Mike


#5

I can see the framework only in “Link Binary with Libraries”.
Frameworks(TwitterKit.framework, Fabric.framework, TwitterCore.framework, Crashlytics.framework) are in “Link Binary with Libraries” not in “Copy Bundle Resources”.

However, TwitterKitResources.bundle is in “Copy Bundle Resources”.
If i remove TwitterKitResources.bundle from “Copy Bundle Resources”, error occured as follows when i run the app,

*** Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: 'TwitterKitResources.bundle file not found. Please use the Fabric Mac app to ensure TwitterKit is properly set-up.'

Env.

  • El Capitan
  • Xcode 7.1
  • Fabric Version 2.0.2 (1049)

Takeshi.


#6

Thanks @takecian. Can you try this out? Open up Fabric.app and click on the app selector in the top-left corner. Then hit +New App and re-install Twitter Kit and let me know how that goes!


#7

Thanks @bonnell, i will try re-install .


#8

After re-install, it worked!

Thank you!


#9

Glad to hear it @takecian and happy coding!