TwitterKit' was built without full bitcode


#1

ld: bitcode bundle could not be generated because ‘/Users/utkudalmaz/Developer/Jemiyet/Pods/TwitterKit/iOS/TwitterKit.framework/TwitterKit’ was built without full bitcode. All frameworks and dylibs for bitcode must be generated from Xcode Archive or Install build file ‘/Users/utkudalmaz/Developer/Jemiyet/Pods/TwitterKit/iOS/TwitterKit.framework/TwitterKit’ for architecture arm64

Cannot archieve the project. Anyone having the same?

Using TwitterCore (3.0.1)
Using TwitterKit (3.2.0)


#2

+1 I need a fix for this since my team is planning for a Appstore release.


#3

I have the same issue.
XCode Version 9.0 (9A235)
TwitterCore (3.0.1)
TwitterKit (3.2.0)

You can solve the issue by installing good-old TwitterKit 3.1.1


#4

Hi all, we are looking into this at the moment. There was an error that went into production so we rolled back to 3.1.1. You can do pod update. Thank you for your patience.


Can not archive TwitterKit with Bitcode enabled in Xcode 8.3
#5

We updated our 3.2.1 release. This also requires 3.0.2 for TwitterCore. Please let us know if you have any issues with archive. Thank you!