TwitterCore.framework version (1.15.2) doesn't match TwitterKit.framework (1.14.6)

ios
twitterkit

#1

I’m trying to integrate Twitter in my app using Fabric but I’m getting the following error after my app immediate crashes upon launching. I’m using Xcode 7.2.1 and Fabric 2.1.2

Terminating app due to uncaught exception ‘NSInternalInconsistencyException’, reason: ‘TwitterCore.framework version (1.15.2) doesn’t match TwitterKit.framework (1.14.6). Please, make sure both kits are up to date.’

I understand this topic was brought up, and subsequently closed, back on Jan 12th but I don’t see a solution posted.


#2

Hi, thanks for the question.

You will need to make sure that you are using the same version of TwitterKit and TwitterCore. It looks like you may have updated one of our libraries (TwitterCore) but not another (TwitterKit).