Twitter widget - twitter-timeline-error

widgetsjs
mootools

#1

After changing template of my joomla website the twitter widget has stopped working. Instead of actual div i got this error:

<a class="twitter-timeline twitter-timeline-error" href="https://twitter.com/xxx" data-widget-id="1111" data-twitter-extracted-i1440024180076181292="true">Tweets by @xxx</a>

How can i fix this?


#2

Can you please share a sample URL on your Joomla site?


#3

Thank you for your response. This is the page: http://www.facebooklikebox.net/demo/index.php/fls


#4

Your page includes MooTools 1.4.5 compiled with compatibility mode enabled. MooTools compatibility mode overrides modern browser interfaces, breaking JavaScript such as Twitter’s widgets-js relying on those interfaces. Updating your JavaScript to a nocompat version of MooTools should fix the issue.
http://www.facebooklikebox.net/demo/media/system/js/mootools-core.js

Build a new version of MooTools with the compat layer build option left unchecked.
http://mootools.net/core/builder

You could also use a hosted version on a CDN, swapping your current script src. Look for nocompat in the filename to indicate the hosted JavaScript was compiled without the compatibility flag enabled.


#5