Twitter widget (tweetbox widget) has disappeared


#1

twitter widget (tweetbox widget) has disappeared. I did not disable Javascript, and did not change any settings on my site. I has worked for the last few months, so why did it disappear this morning? I tried to uninstall and then reinstall but the results are the same, none of my browsers show the widget.

It worked until this morning, then… nothing… nothing but a blank screen.
Here is the code which the widget creation page from twitter gives me, but which no longer works:


#2

i have this exact same problem. Did you find a solution?


#3

I’m having the same problem. This is really annoying. It does display once the page is published live on the web but it will not display from any file located on my computer.


#4

I completely removed the code for the tweet box, and waited about an hour, then reinstalled the code into my page. I tried varying amounts of time, until I reached the one hour mark. I don’t know why it took that long with my site, and don’t know if it takes that long with everyone, but that is how I fixed it.


#5

It sounds like you may have run into the API rate limit. I may have as well but I had the issue right from the get go today. I haven’t worked on my site in a couple of weeks so I can’t imagine why there would be any issue with running into a ping limit. Also I’ve been working on this for several hours and the only way I can get the twitter box to display is by saving local copies of widget.js and widget.css but even then not all of the images load and the page loads slowly. I’ve been looking into the problem with firebug and it appears that widget.js is being downloaded but not executed and widget.css isn’t even downloaded (because the code that downloads the css file is in the js file - which also explains why nothing displays). The widget is behaving the same in all of my browsers, which makes me think maybe it has to do with my having limited access to widgets.twimg.com however I can manually go to that site and access all of the files on it. I wonder if my requests are being blocked from my ip address or by a cookie? Very peculiar. I will take your advice and let it be for an hour.


#6

Just wondering if that fixed the problem for you. I hope so, if not keep in touch and we’ll keep throwing around ideas until it is fixed…


#7

Hi guys

I also have this problem AND i don’t know what to do… Please help me.

I made my first app for Android AND iOS … One menu item is called tweets, when you click ON it you see à twitterbox ( i made that with THE profile embedd code from THE website of twitter) AND it is working fine! ON iPhone but also other devices it Showed THE tweets from the profile i wanted… But since (yesterday or one day before yesterday) … THE widget disappeared… When i click ON tweets in my app it’s not schowing anything anymore… Totally gone. But i did not changes anything … THE problem is i can’t edit my app anymore AND THE event for this app starts friday? What can i do? This has to be àn error from twitter right? …

I’m sorry voor THE bad english. I hope you can help.


#8

What also was very strange: when i was working local it showed the widget fine… But since yesterday THE widget disappeared… It’s not showing anything anymore. It’s only working when i put it online…


#9

you could try including the http://widgets.twimg.com/j/2/widget.css inline your page- that’s been working for me, but it doesn’t load the twitter logo which is a bit annoying.


#10

Try using iframes, put the code for the tweetbox on a separate page, and on the page you want it to show up in you put an iframe which pulls up the page where the code is. If it does not have the logo, upload a logo to your server or host, and use the img src tag to place the logo just above the iframe. Not sure if this works in Android or iOS but it works for Windows servers and Hosts, and should work for Linux.


#11

The solution for displaying the Twitter widget and logo client side (locally) is:

The widget is displayed properly and also the Twitter logo is visible. Good luck!


#12

Going to give this 1 hour waiting period with the widget code completely removed — I’ll let you all know how it goes.


#13

Still nothing after an hour. It’s weird though. The tweet data is pulled into the HTML (I can view it in FireBug) but isn’t being displayed. Makes me think something weird is going on with the styling.


#14

That was the case. Dang it!


#15

Looks like a common problem. I hope that someone finds a solution soon. I have got the weekend free so I might have a play around. If I find a solution I will be sure to post it.


#16

Hi all, The solution was very simple. Open up the widget settings and in the Domains box add your domain exactly how it appears in your browser. I have added two settings. I used http://tagwebsites.com.au and then separated it with a comma and then added www.tagwebsites.com.au. That fixed it. If you open your javascript console(F12) and click on console while your main website is open it actually displays the error and tells you how to fix it. Hope this helps.


#17

Aewsome! My javascript console showed the error: the widget was being deprecated and you should update it here: https://twitter.com/settings/widgets/new/user?screen_name=YOUR_USERNAME


#18