Twitter widget not working in firefox


#1

I have today installed the twitter widget on my website, however it wont work in firefox, just says ‘tweets by @account’, however works fine in all other browsers.

did some research and all i can find is people saying its because i havnt added the domain correctly, however just found out that isnt a feature anymore?

anyone had this issue or got any solutions?

regards.


#2

I’ve been having the same issue. Any one found a reason/solution yet?


#3

I posted the same problem to Twitter, did not get any reply yet. In fact I did not get any reaction at all.
My problem is: The same webpage (with new twitter timeline widget) does work in IE and in Chrome, but fails in Firefox end Safari. It just shows the link. Must be the javascript that expands and replaces the link. There must be a bug in it. Twitter please HELP!


#4

Found the solution!!!
I grabbed the javascript file https://platform.twitter.com/widgets.js (using Ctrl-A and Ctrl-C) and saved it to a ‘local’ file using Ctrl-V (on the server of my website) as widgest.js.
I added a link to it in the head session of my weppage like:
If you want you can remove the code: js.src=p+"://platform.twitter.com/widgets.js"; from the widget-text,
ET VOILA the twitter widget works in Firefox and in Safari as well, as in all other browsers!!


#5

Theo, I can’t thank you enough! Been reading thru many other threads to fix this issue with Firefox, I followed your instructions & the timeline is back up & running using Firefox! Thanks again for figuring this out & taking the time to share!


#6

Please do not copy widgets.js locally. As soon as there’s any change to how the widgets work it will stop working. If you have a problem with that code, you can use:

or:

#7

I tried the above suggestion & it does not work, but thanks for the heads up. The original fix is working for now.


Embedded Code for Timeline Stopped displaying Tweets
#8

Meaby u have a spam blocker activate as an addon of firefox.


#9

Used to work on Firefox even a few months ago (8/2015). Apparently either Firefox had an update or two, or it has something to do with Windows 10 that I installed on my computer.

Either way notice how quickly Twitter cares to respond to anyone on this site, or to fix the widget - not. Annoying.


#10

Hi all,

Lot of time to fix this problem :slightly_smiling:

After try some solutions describe on this post (without efficient result) I’ve just unchecked the “block the popup windows” in Firefox : preferences => content.

And that’s work perfectly… But remember that is a default option of Firefox. So managable in an Intranet/Extranet, not on a public website ;(

Happy new year 2016 to all,

LMJ


#11