Twitter Widget is not working consistently


#1

We have implemented the new twitter widget in the last week and able to run the website. However the functionality of the widget is inconsistent and its appearance is on and off since the implementation. Basically it will show quite poor performance with IE10 browser most of the times.

During the failure attempts, the twitter widget is not even showing its preview in the twitter settings page. When monitoring the network calls, in a successful attempt, I can see the script is performing a GET request for the URL http://platform.twitter.com/widgets.js and get a GET 304 with a Data as a response. In unsuccessful occasions, it will return a GET 200 with some data. During the unsuccessful attempt, the web application is stopping requesting further from twitter.

The following code illustrate the data widget I have created in Twitter page. Note that I have removed the http, https condition and used the path (http://platform.twitter.com/widgets.js) in the code. I am pretty sure (have tested) that it’s not affecting at all.

[HTML]

<a> class="twitter-timeline" href="https://twitter.com/DigitalOpinion_" data-widget-id="379896136279941120" width="180" height="260">Tweets by @DigitalOpinion_ </a>

<script>
    ! function(d, s, id) {
        var js, fjs = d.getElementsByTagName(s)[0];
        if (!d.getElementById(id)) {
            js = d.createElement(s);
            js.id = id;
            js.src = "http://platform.twitter.com/widgets.js";
            fjs.parentNode.insertBefore(js, fjs);
        }
    }(document, "script", "twitter-wjs");
</script>

Please let me know, if you need any further clarifications or if you have any idea about this problem. Thanks for considering my question.


#2