Twitter widget is not showing on chrome


#1

I have a wordpress blog and recently I’ve added the official Twitter widget to my side bar.
It works perfectly fine on Internet explorer but is not working properly on chrome browser.
On chrome it either not shown at all or shown for less than a second and then disappear.
This is the link for my site (it’s in hebrew) - erech-muhlat.com
Would appreciate any assistance…
Thanks in advance.


#2

Having the similar issue expect but only shows in firefox not in explorer, chrome or safari. Has some thing changed recently?
Thanks in advance.


#3

Same problem here on Chrome since last update (Version 29.0.1547.66 m).
Timeline doesn’t show on Chrome but shows on IE.


#4

Same here, sometimes works but most of the time not. Works fine in other browsers.


#5

I had the same problem, fixed it by changing twitter code to include the widget library to:

// Twitter API !function (d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; //, p = /^http:/.test(d.location) ? 'http' : 'https'; if (!d.getElementById(id)) { js = d.createElement(s); js.id = id; // js.src = p + '://platform.twitter.com/widgets.js'; js.src = "https://platform.twitter.com/widgets.js"; fjs.parentNode.insertBefore(js, fjs); } } (document, 'script', 'twitter-wjs');

in the JS comments u can see what I changed from Twitter’s orig code.
Weird error, Twitter must have changed something internally in that base lib.
In case this helps others.


#6

Update to my prev post, which btw the moderator hasn’t approved yet, hours after! Kind of defeats the purpose of a forum, right Mr. Twitter Moderator? Posting this too? :wink:

My prev post was a patch or workaround, but the real problem was just in Chrome Version 29.0.1547.76 m, or its caching behavior, or cached files. So, I fixed it finally by clearing out the cached files (Settings “Empty the cache”). So it looks like it was a temp bug.

Cheers!

ps: Make sure to close all Chrome apps/instances/windows after clearing this cache.


#7

Opposite issue. Twitter widget (based on HTML code) not showing up on my Blogger website - in IE. Chrome and Safari are fine.

  • I even tried copying existing, working code from another of my blogs and changing the Twitter handle. No go.

#8

In my case the problem was Avast plugin in Chrome. By default, Avast blocks social networks and running applications. You have to deactivate this protection manually if it’s a secure website. Avast logo locates at the upper right site of Chrome where you can see the number of issues you have to resolve. After deactivating blocking, my twitter widget came up again. Follow me at @maxdataVE or visit www.maxdata.com.ve


#9

My Twitter feed is also gone, only the text link shows. I see that yours is not working again either - all I can see is the same type of link I see on my site (mariaerving.com) It worked fine before but now for the past few days it has not shown. Hope someone can help with this matter.


#10

Oops wrote the same comment twice and can’t use delete.


#11

My Twitter feed is also gone, only the text link shows. I see that yours is not working again either - all I can see is the same type of link I see on my site (mariaerving.com) It worked fine before but now for the past few days it has not shown. Hope someone can help with this matter.


#12

I had same problem with tweets not appearing in Chrome browser, disabled "Do Not track Me"
extension all working OK. Try disabling any extensions you have one at a time.


#13

Thank you for the suggestion, but I don’t use any extensions. The feed has worked fine before but all I see now is the link (Tweets by @mariaerving). Same thing with Firefox. Very strange.


#14

If you have Avast antivirus installed as an extention in Chome it may disable twitter widget. In Chome try ty click right Avast icon and chose the menu Social networks blocked / Twitter (switch Off blocking) It works for me in Chrome


#15

Awesome! That was it! Now the Twitter feed is showing again. Thank you, I really appreciate it:) Have a great day and happy weekend! /Maria


#16

Brilliant! This was driving me nuts :slight_smile:


#17

Omgsh! This worked! Thank you! I turned off the plugin and had to repaste in the code to my blogger widget, but after I clicked refresh everything worked fine. Awesome! XD


#18

That answer is perfect, thank you very much, resolved the issue straight away!!


#19

This is the problem, Avast plugin, deactivate it solve the problem. Thank so much for your post!!!


#20

Brilliant @Internoid . Thats solved it! :slight_smile: