Twitter timeline widget suddenly stopped working, official code not helping


#1

As of this afternoon (6 pm, Central European time +1), the embedded Twitter widget on the right side of my website ( http://igniss.blog.hr/ ) has stopped working. I at first thought that was due to deleting a completely unrelated hit counter from my page, but I have since rolled back the entire website code to a version that worked a week ago and nothing changed.

The code in question is this:

<a class="twitter-timeline" width="320" height="500" data-border-color="#FF8000" background: "#FF8000" noscrollbar:true href="https://twitter.com/Ignissblog" data-widget-id="345923356262006785">Tweets by @Ignissblog</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id))  {js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>

<p>
<ul>
<li><script src="http://widgets.twimg.com/j/2/widget.js"></script>
<script>
new TWTR.Widget({
  version: 2,
  type: 'profile',
  rpp: 5,
  interval: 6000,
  width: 215,
  height: 360,
  theme: {
    shell: {
      background: '#b07221',
      color: '#ffffff'
    },
    tweets: {
      background: '#241f24',
      color: '#ffffff',
      links: '#e09b12'
    }
  },
  features: {
    scrollbar: false,
    loop: false,
    live: false,
    hashtags: false,
    timestamp: true,
    avatars: false,
    behavior: 'all'
  }
}).render().setUser('Ignissblog').start();
</script></li>
</ul>
</p>

Which produces just the “Tweets by Igniss” link and a tiny black dot (screenshot):

Googling around produced many suggestions to change the domain name in my Widget creation menu on Twitter, but there is no such field in that menu. I created an entirely new widget and copy/pasted its code but it doesn’t work either:

Tweets by @Ignissblog

The result is the same except that this one doesn’t even produce the black dot under the link.

I tried adding http or https to before the ://platform part as per another instruction, but it didn’t affect anything. This code:

Tweets by @Ignissblog

Tweets by @Ignissblog

Tweets by @Ignissblog

… produces only this (screenshot):

I’ve also tried putting the script part at the beginning of the head and/or body section of my html, but that also did nothing.

I’m completely out of options now. Can anyone help?


#2

I’ve discovered that this was due to my Avast (also recently installed) blocking all of my social network addons on the webpage. The feed is working fine now so this problem can be considered solved.


#3

#4

#5

#6