Twitter Timeline Widget not showing

widgetsjs
embeddedtimeline

#1

I have tried many things to get this working. At first I just had the code given on the widget page copied into the page. Then I tried adding loading the widgets.js file asynchronously as it is suggested in the documentation. Everything I have read makes me think this should be working but it isn’t. Please see the attached GIST. This is the source of my static HTML page that won’t show a timeline.


#2

Hi Dana,

I downloaded the page from your gist (thank you for uploading the whole thing, by the way, very helpful for debugging) and when I ran it locally the timeline rendered just fine. We’ll need to narrow down exactly what’s going on.

  • First up, can you confirm which browser you’re testing in, and whether the timeline is broken in all browsers you try?
  • If it is broken everywhere, do you have any system-wide ad blocker or internet security extension running?
  • If not, maybe we can confirm the type of failure a little better: Do you see an empty space where the widget should be, or a simple link to your timeline on Twitter?

Thanks,

Ben


#3

Thanks for the help. It was an ad blocker. Once I whitelisted my site, the timeline shows up. Since this is not an ad I never thought about the ad blocker causing this. There was also no error in the console. Do you know of anyway to prevent the ad blockers from seeing this as something that should be blocked?


#4

Which ad blocker are you using? It’s usually possible to add or remove rules in the settings of an ad blocker.


#5

Actually, I already have a solution within my ad blocker. I was more looking for a way to avoid this for my site’s visitors. I think I might just put a short word about turning off ad blockers to see the timeline.


#6